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Welcome to the Analyze 10.0 Essential Training Guide. This document provides an overview of Analyze 10.0 core functionality through 56 exercises 
that guide new users step-by-step through basic and advanced Analyze procedures. A fully comprehensive overview of all Analyze 10.0 module 
functionality can be found in the User’s Guide and Tutorials located under the Help menu within the software. If you have not installed Analyze 10.0, 
please refer to the Analyze 10.0 Installation Instructions provided with the software.

In order to work through the Essential Training Guide 
exercises and Analyze Tutorials, you need to install the 
tutorial Data from the Resources CD. To install the tutorial 
Data:

1.	 Insert the Analyze Resources CD into your computer.

2.	 Open Analyze 10.0 and choose Help > Tutorials.

3.	 Click Install Tutorial Data at the bottom of the 
Tutorials window. Note, if the tutorial data has already 
been installed this button will not appear.

4.	 In the window returned, specify the path to the tutorial 
data, for example D:\TutorialData (where D:\ is equal 
to your CD-ROM drive).

5.	 Click Install. All of the tutorial data will be copied from 
the Resources disk to the $:\BIR\images\TutorialData 
folder (where $ is the install directory, e.g. C:\ on a 
Windows system).

Button Reference: Displays PowerBar button or tool button 
referenced in that exercise step. The button will be next to the 
step that it refers to. Often, the step only mentions the file path, 
but the button is displayed as a shortcut. Example:

Open the DICOM Tool (File > DICOM Tool).

Installing Tutorial Data Quick Reference

Introduction
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The main Analyze window is the first operational 
window that appears when Analyze is opened. 
The main Analyze window does not perform any 
imaging functions, but it does coordinate all the 
modules within the Analyze package and acts as 
a file manager for loaded data. It consists of three 
major components: the Analyze workspace, 
where all of the loaded data, represented as icons 
are managed; the Analyze menu, where individual 
Analyze modules are selected; and the Analyze 
PowerBar, which provides icon-based shortcuts to 
the most frequently used Analyze modules

Image data is loaded into Analyze using one of the load modules 
(Load, Load As, DICOM Tool, or Import/Export) from the ‘File’ menu in 
the main Analyze window. Most of the individual Analyze modules also 
support data loading directly within the module (File > Load within the 
module).

To load DICOM data, use the DICOM module, for more information on 
how to use this module, please refer to Exercises 1-2 of this Guide.

To load all other data into Analyze, refer to Exercises 3-6 of this 
Guide.

The tutorial data used in the Essential Training Guide exercises can 
be loaded into Analyze using the Load module (File > Load). It is 
assumed that the data was installed to $:\BIR\images\TutorialData 
(where $ is the install directory, e.g. C:\ on a Windows system) 
according to the “Installing Tutorial Data” instructions on page 6.

Analyze Menu

PowerBar

Tabbed Analyze Workspace

Image Data Icon

The Main Analyze Window

Analyze Basics

Loading Data into Analyze
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Once data is loaded into Analyze it will appear as an icon in the Analyze workspace and is available to all of the 
modules in the Analyze package. To load data into a module, select the image icon in the Analyze workspace 
(the icon will appear framed in red when selected) and open the desired module from the Analyze menu or 
PowerBar. If multiple icons are selected at the time the module is opened, one of the two actions will occur:

1.	 If the opened module supports or requires multiple volumes, the volumes are used in the order selected.

2.	 If multiple loaded volumes are not supported, then multiple instances of the module are invoked.

The Analyze Workspace

note	 To select multiple data sets 
hold down the <Ctrl> key while 
making selections with the mouse. 
Alternatively use the left mouse 
button to select the first data set  
and the middle button (if available) 
to select additional data sets.

Analyze Basics



Analyze 10.0 Essential Training Guide 9

The Analyze workspace is an area with additional options. When the right mouse button is clicked in the 
workspace, a menu will appear. The menu provides the following options:

•	 Unload: Unload selected data from the Analyze workspace
•	 Info: Display the header information for a selected data set
•	 Rename: Change the name of a selected data set
•	 Edit Header: Modify the header information of a selected data set
•	 Append: Append selected data
•	 Unappend: Unappend 4D multi-volume data sets, or RGB data sets
•	 Select All: Select all data sets in the Analyze workspace
•	 Invert Selected: Invert your selection of data in the Analyze workspace
•	 Arrange: Arrange data sets by Name, Size or Modify Time
•	 Current Directory: View and modify the Current Directory location
•	 Workspace Directory: View and modify the Workspace Directory location
•	 Session Log: Stores information that might be useful to the Analyze support team and software 

developers, should a problem ever arise with one of the modules.

Right Mouse Button Menu

<Ctrl><a> Selects all of the files in the workspace.

<Shift><Left Mouse Click> Selects all files between first and shifted selections.

Double clicking on a data set in the workspace restarts the last module used with that data. If there is 
not a module associated with the data, the Multiplanar Sections module will open by default.

Main Analyze Window Quick Keys

Analyze Basics
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The File menu contains the modules that are used to input and 
output data, as well as the standard ‘Save’, ‘Save As’ and ‘Exit’ 
options.

The Display menu contains the Analyze modules that involve the 
display, visualization, and manipulation of image data:

Multiplanar Sections
Oblique Sections
Volume Compare
Volume Render
Surface Render
Virtual Endoscopy
Movie

The Process menu contains the Analyze modules that are used for 
processing and classifying image data:

Image Calculator
Image Algebra
Histogram Ops
Spatial Filters
Filter Designer
3-D FFT

The Segment menu provides facilities for image segmentation:
Image Edit
Morphology
Watershed
Multispectral Classification
Object Extractor
Surface Extractor

The Analyze Menu

The Register menu contains all of the Analyze tools for image 
registration:

2-D Registration
2-D Non-rigid Registration
Point to Surface
3-D Surface Registration
3-D Voxel Registration
3-D Non-rigid Registration

The Measure menu contains an extensive selection of measurement 
modules:

Line Profile
Region of Interest
Stereology
Object Counter 
Tree Analysis

The Apps menu option contains add-on modules available for Analyze:
SISCOM
Mayo 3-D Brain Atlas*
DTI*
T2 Projection*
Volume Metrics*

The ITK menu contains modules that provide access to the Insight 
Toolkit (ITK):

Filter
Segment 2-D
Segment 3-D
Registration

*These modules require the purchase of an additional license

Analyze Basics
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Additional items available in the Analyze menu include:

The Other menu contains utilities and modules for configuration and 
resource monitoring.

•	 Resources: The Resource Monitor assists in maintaining 
system resources at a level that does not impede proper 
execution of Analyze. The resources being monitored and 
displayed are Swap space, Workspace, and user specified 
directory Disk space. For all three, the Resource Monitor reports 
the amount of space used, space available or free, and total 
capacity.

•	 PowerBar Editor: the PowerBar Editor is an option that 
appears in all Analyze modules that contain PowerBar options.

•	 Options: The Options item allows you to switch on and off 
workspace features such as the PowerBar, and the pop-up icon 
names which are shown when the mouse cursor is moved over 
an image in the workspace. You can also configure Add-On 
modules to be switched on or off.

•	 AppDefaults Editor: The AppDefaults Editor provides several 
tools for managing and changing defaults or user preferences 
for the Analyze workspace and specific Analyze modules. 
For further information about the AppDefaults Editor please 
reference the User’s Guide (Help > User’s Guide).

The Help menu provides access to several important Analyze 
resources:

•	 User’s Guide: Provides detailed information on each Analyze 
module.

•	 Tip of the Day: Can be set to display an Analyze “tip” each time 
Analyze is opened.

•	 Tutorials: Tutorial exercises covering some of the main Analyze 
functions. Note, you must have selected to install the Tutorials 
during initial Analyze installation.

•	 Analyze Update: Checks to make sure Analyze is up-to-date, 
also will download and install any necessary updates.

•	 Online Support: Provides a direct link to the AnalyzeDirect 
Support home page.

•	 Analyze Demos: Provides a direct link to a list of Help Movies
•	 Copyrights: Documentation of Analyze Copyrights.
•	 About: Provides version, system, and environment information.

The Analyze Menu

11

Analyze Basics
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Directly below the menu bar in the main Analyze window you will find the PowerBar of icons. 
The icons on this main Analyze PowerBar provide shortcuts to the most commonly used 
Analyze modules. By default, the main Analyze PowerBar contains icons for:

In addition to the main Analyze window, you can also find a PowerBar in each Analyze module.  The icons included on the PowerBar of each 
Analyze module provide shortcuts to the most commonly used tools and options within that specific module. 

Main Analyze PowerBar

Module-Specific PowerBars

Customizing Analyze PowerBars is a quick and easy way to streamline 
your work flows and routine processes.  To customize the PowerBar 
displayed within any Analyze window, you can use the PowerBar Editor 
found under the window’s ‘Other’ menu (Other > PowerBar Editor).  

PowerBar Editor - Customizing PowerBars

Load As, DICOM Tool, Multiplanar Sections, Oblique Sections, Volume Render, Movie, 
Object Extractor, 3D Voxel Registration, Region of Interest, and Exit.

Using the PowerBar Editor [A], you can:
•	 Add/Remove PowerBar icons: To add an icon to the 

PowerBar, select it in the PowerBar Editor list (selected icons 
appear highlighted in black). To remove an icon, deselect it in 
the PowerBar Editor list.

•	 Change the order of PowerBar icons [B]:  With the PowerBar 
Editor open, drag-and-drop an icon on the PowerBar to a new 
location.

•	 Create additional PowerBars: To create multiple PowerBars 
for the main Analyze window or an Analyze module, click the 
New button [C] in the PowerBar Editor and then select the 
desired icons for the new PowerBar.  You can scroll through the 
PowerBars using the up/down arrow buttons added to the far 
left of the PowerBar [D].

note	 Be sure to press Save [E] in the PowerBar 
Editor if you wish to keep your PowerBar 
changes for future sessions.  Otherwise, 
changes will be lost upon existing the Analyze 
module, or Analyze.

Analyze Basics
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Loading Data
Into Analyze

Analyze 10.0
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The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. This 
exercise will demonstrate how to create a database and then how to import DICOM data into the database.
Note: If you are a previous BirPacs user please contact support@analyzedirect.com for instructions on migrating your database to the DICOM Tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 The DICOM Tool will detect that there is no database present; a dialog box will be 
returned asking you if you would like to create a new database or browse for an 
existing database, click Create a new local database.

3.	 The Create New Image Database window (Figure 1) allows you to specify a 
database name and file system directory, configure a DICOM receiver for the 
database (optional), configure a database server (optional), and specify the source of 
initial DICOM images (optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; chance the 
Local Database Name to TEST_5679 [A].

5.	 On your system’s local disk create a folder called ‘AnalyzeDB’ ($:/AnalyzeDB)

6.	 Click the Local Database Directory button in the Create New Image Database 
window.

7.	 In the Browse for Folder window returned navigate to the location of the new 
‘AnalyzeDB’ folder ($:/AnalyzeDB), select the folder, and click OK. You have now 
specified the location of your local database [B].

8.	 To create the local database click the Create Local Database button [C].

9.	 Once the database has been created a dialog box will be returned stating ‘All Done’, 
click OK.

note	 If this is not the first time you have accessed the DICOM Tool, you can access the 
Create New Image Database window by selecting File > Create Database.

Figure 1

Exercise 1 : DICOM Tool Quick Configuration
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10.	 To import DICOM data into the DICOM Tool right-click anywhere in the white space 
and select Import DICOM Images from the menu (Figure 2). Alternatively, select File 
> Import DICOM Images.

11.	 In the Browse for Folder window returned navigate to and select the folder $:\BIR\
images\TutorialData\ImportExportTutorial, then click OK.

12.	 A dialog box will be returned asking you to confirm that you would like to ‘Import all 
DICOM files found below <C:/BIR/images/TutorialData/ImportExportTutorial>’, click 
Yes to confirm.

13.	 All 121 DICOM images contained within the folder will be copied into the database. 
The DICOM Tool will automatically sort and index the data by patient, study, series, 
and volume.

14.	 Data can be selected and viewed in the DICOM Tool (Figure 3). To load a selected 
data set into the Analyze workspace click Load Volume [D]; if you wish to resize or 
resample the data click Load As, this will load the selected data into the Load As 
module (see exercise 4 for instructions on how to use the Load As module).

Figure 2

Figure 3

Exercise 1 : DICOM Tool Quick Configuration
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The DICOM Tool expands DICOM support in Analyze, enabling the indexing of collections of DICOM images through a local database file. With the DICOM 
Tool, databases can be created, updated, and shared with other users with file system access to the images and the database file. This exercise will 
demonstrate how to create a database, configure a DICOM receiver and Database sender and then how to import DICOM data into the database.
Note: If you are a previous BirPac user please contact support@analyzedirect.com for instructions on migrating your database to DICOM tool.

1.	 Open the DICOM Tool (File > DICOM Tool).

2.	 If you have already completed exercise 1, choose File > Create Database. If the 
DICOM Tool detects that no database is present, a dialog box will be returned asking 
you if you would like to create a new database or browse for an existing database, 
click Create a new local database.

3.	 In the Create New Image Database window you can specify the database name and 
file system directory, specify a DICOM receiver for the database (optional), specify 
database server (optional), and specify the source of initial DICOM images (optional).

4.	 The Local Database Name will default to ‘SystemName_PortNumber’; change the 
Local Database Name to TEST2_5679.

5.	 The Local Database Directory option enables you to specify the directory on your 
system in which the database and all of the DICOM images will be stored.

note	 Any name can be chosen for the local database, however when creating multiple 
databases, following a coherent naming convention will simplify database management.

i.	 On your system’s local disk create a folder called ‘AnalyzeDB’ ($:/AnalyzeDB). 
Note that if you have completed exercise 1, DICOM Tool - Quick Configuration, 
this 	 folder should already exist.

ii.	 Once the directory has been created, click Local Database Directory [A] in the 
Create New Image Database window, and navigate to the location of the new 	
‘AnalyzeDB’ folder ($:/AnalyzeDB).

iii.	 Select the folder and click OK. You have now specified the location of your 			 
database.

Figure 1

Exercise 2 : DICOM Tool Advanced

Specification of the Database Name and Directory
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6.	 The Configure DICOM Receiver option allows you to configure a DICOM receiver for 
the database.  This step is optional, if you do not want to configure the receiver please 
move on to step 8, otherwise check the Configure DICOM Receiver option [B].

7.	 DICOM Receiver configuration requires three key pieces of information:  the Receiver 
AET, the Receiver Port on the local system, and the directory where the DCMTK 
executable programs are installed.

i.	 DICOM Receiver AET: By default is set to ‘SystemName_PortNumber’.  To 
reflect the receiver’s connection to the database defined in step 4, change the 
DICOM Receiver AET to TEST2_5679.

ii.	 DICOM Receiver Port: Specifies the TCP/IP port number on which the DICOM 
Receiver listens for connections to receive messages.  For this exercise, the 
DICOM Receiver Port can remain 5679.

iii.	 DCMTK Path: The DCMTK executable files are automatically installed with 
Analyze in the $:\BIR\DCMTK-3.5\$System_Type$\bin directory (where 
$System_Type$ is your system platform, e.g. PC_NT) and the DCMTK Path will 
point to this directory by default.  However, if Analyze is being run from a network 
rather than local installation, the DCMTK files should be installed locally and this 
path should point there.

Specification of a DICOM Receiver (optional)

Exercise 2 : DICOM Tool Advanced
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8.	 The Configure Database Server option allows you to configure an optional database 
server to manage automatic updates and multiple client access to the database over 
a network.  The database server is a dedicated process attached to one database and 
accessible by system name and port number.  It responds to connection requests, 
SQL statements, and requests for images, and polls the image storage area for newly 
received images to register.  Configuring and installing a database server is very 
similar to configuring the DICOM receiver.  This step is optional, if you do not want 
to configure the database server please move on to step 10, otherwise check the 
Configure Database Server option [C].

9.	 The Database Server fields are used to configure the database server process that 
controls access to the database.

i.	 Service Name: The name by which the servicer is identified, for this exercise 
use TEST2_5679.

ii.	 Host System: Identifies the system name this program is running on. You can 
create servers to run on your system, and any server should be attached to a 
database local file system. 

iii.	 Port Number: Specifies the port number client systems will use to connect to 
server.  It cannot be the same port as the one used by the DICOM receiver 
(STORESCP).  For this exercise set the port to 5680.

iv.	 Update Frequency: Specifies the interval in minutes at which the server will poll 
the image storage directory to see if the DICOM receiver has deposited images 
to be in the database.  For this exercise, you can leave this set to 5.

v.	 Server Logging: Creates a log file of the database server for diagnostics.  

note	 On Windows systems this becomes the name of the Windows Service; on UNIX 
systems it is used to name the daemon script which starts, stops and checks 
server status.

  tip	 It is recommend using a closely related port 
number so they can be easily remembered; 
e.g., if the receiver is running at port n, run 
that database server at port n+1.

Specification of a Database Server (optional)

Exercise 2 : DICOM Tool Advanced
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10.	 The Source of Initial Images option allows you to specify a directory containing 
DICOM images; click Source of Initial Images [D].

11.	 In the Browse for Folder window returned, navigate to the $:\BIR\images\
TutorialData directory, select the ImportExportTutorial folder, and click OK.

12.	 To create the local database, click Create Database Server [E].  Note, creating a 
Database Server requires administrative privileges; a dialog box will automatically be 
returned stating that you will receive a prompt from your operating system, click OK.  
You will then need to enter the administrator password.

13.	 The DICOM Tool will now copy the DICOM images from the initial source to the 
location (if selected) specified in step 5. The data will automatically be sorted and 
indexed by patient, study, series, and volume. 

14.	 Once the process is complete, the Create New Image Database window will 
automatically be dismissed and the data will now be available in the DICOM Tool 
(figure 2).

15.	 Data can be selected from the Patient information panel [F] in the DICOM Tool. 

16.	 Select the data set with the ‘Patient Name’ MR SIGNA LX 1.0T and ‘Patient ID’ 337.  
The data set will be highlighted, note the other information panels will automatically 
update with relevant Study, Series, and Volume information (when available).  

17.	 Note there are two data sets available for selection in the Series information panel [G] 
below.  Select Series 102.  

Figure 2

Viewing and Loading Data

Creating the Database Server

Specification of the Source of Initial Images (optional)

Exercise 2 : DICOM Tool Advanced
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18.	 Review the data slice-by-slice by using the Slice Number slider bar under the image 
display.  

19.	 Right-click on the image display to open the Intensity window (figure 3).  Here you 
can change the intensity display of the image; use the slider bar to take the Maximum 
intensity level down to 500.  The image display will interactively update.  Click Done to 
dismiss the Intensity window.  

20.	 To load this data set into the Analyze workspace, click Load Volume.  The data set 
will automatically load into the Analyze workspace.

21.	 Move the cursor over any of the information panels and right-click.  The menu 
returned provides most of the options available for management of the images in the 
DICOM database, these options include:

Refresh: Deselects any selected data and refreshes the data
Configure Columns: Configure the column properties for the data display
Configure Search: Focus the scope of the displayed data with an information 		
	 search
Show Server Info: Enable/disable display of recent databases and remote AETs
Update DB: Register any recently received unregistered images in the database
Query Current AET: Perform query retrieve on remote AET to retrieve images
DB Update Status: Enable/disable display of Database Update Status
Import DICOM Images: Copy and register images from the file system to the 		
	 database
Load Patient: Load patient data from files
Export Patient: Export patient data to files
Delete Patient: Delete the patient data from the database
Send Patient: Send patient data to listening server
Anonymize Patient: Anonymize the patient information (only available from the 	
	 patient pane)

note	 If you wish to resize or resample the data 
use the Load As button option, this will 
load the selected data into the Load As 
module (see exercise 4 for instructions on 
how to use the Load As module).

Figure 3

Other DICOM Tool Options

Exercise 2 : DICOM Tool Advanced
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22.	 On your system’s local disk create a folder called ‘test_export’ ($:/test_export).

23.	 Select the ‘Patient Name’ MR dataset Brain and then right-click and select the 
Export Patient option (figure 4).  

24.	 In the Browse for Folder window returned, navigate to and the new ‘test_export’ 
directory, then click OK.  The DICOM images will be exported out to this directory.  

25.	 Now navigate to the ‘test_export’ directory on your system’s local disk; note the file 
names have changed to new DICOM UIDs.

26.	 In the DICOM Tool, with MR data set Brain still selected, right-click and select the 
Delete Patient option.  

27.	 A dialog box will be returned asking you to confirm that this is what you want to do, 
click Yes.  A delete confirmation window will be returned, click OK to dismiss it.

28.	 To import this data back into the DICOM Tool right-click in any of the information 
panels and select the Import DICOM Images option.  In the window returned 
navigate to and select the ‘test_export’ directory on your system disk, then click OK.  

29.	 You will be asked if you would like to ‘Import all DICOM files found below 
<$:/test_export >’, click Yes to import these images back into the database.  The data 
will be automatically sorted and imported into the DICOM Tool database, and the data 
set will appear in the Patient information panel.

30.	 Close the DICOM module before proceeding to the next exercise.

  tip	 Multiple databases can be created for the DICOM Tool, so multiple DICOM 
receivers can be configured for the tool; you can select different databases 
from the Local Databases drop-down menu option.

Figure 4

Exercise 2 : DICOM Tool Advanced
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Analyze supports over 45 different file formats. By default, only the most common formats are enabled. The Import/Export module’s External 
Libraries tool can be used to enable and disable these formats. This exercise will show you how to use the External Libraries tool to switch on 
support for additional formats.

1.	 Open the Import/Export module (File > Import/Export).

2.	 To view the file formats currently supported in Analyze, choose Help > Formats.

3.	 File formats currently supported are listed in the bottom ‘Formats’ section of the 
Supported Formats window (figure 1).  When a format is selected, the associated 
properties will automatically become checked in the ‘Properties’ section of the 
window.  Experiment by checking several different formats and noting their properties.  
Click Done to dismiss the window.

4.	 Open the External Libraries tool (Tools > External Libraries).  

5.	 The External Libraries tool provides a graphical interface listing all formats supported 
by Analyze (figure 2). The green and red status indicators note whether a format is 
currently ‘Loaded’ (L) and ‘Configured’ (C) - green indicating yes and red indicating 
no.

6.	 If you wish to switch on support for a specific file format (for example, PICKERMRI), 
click on the format in the External Libraries tool.  A Configure ‘X’ Format window will 
be returned (where ‘X’ is equal to the selected format) (figure 3).

7.	 In the Configure ‘X’ Format window, click Load Now to change the ‘Currently Loaded’ 
status to a green Yes.

note	 Users running multiple operating systems need to configure support for each file format 
for each operating system. The ‘Platforms’ option allows the format to be configured for 
all operating systems (ALL) or for a specific operating system (SPECIFIED).

Figure 1

Figure 2 Figure 3

Exercise 3 : Switching On Support for Additional Formats
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8.	 Click OK.  A dialog box will be returned stating that your ‘EXTEND.conf’ file will be 
updated, click OK (figure 4).  The format is now supported by Analyze.

9.	 If you would like to load and configure all supported formats for your system, click 
Max in the External Libraries tool.  All image file formats will now be supported by 
Analyze.  The ‘L’ and ‘C’ status indicators will appear green next time you open the 
External Libraries tool (figure 5).

10.	 Click Done to close the External Libraries tool.

11.	 Close the Import/Export module before proceeding to the next exercise.

note	 Each file format enabled increases the amount of memory used by your system; it 
also increases the time taken for a module to open. However, this is typically only 
an issue on older systems or systems where memory resources are scarce.

Figure 4

Figure 5

Exercise 3 : Switching on Support for Additional Formats
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Analyze
AnalyzeAVW	 used internally for memory mapping, supports all data 

types, 2D, 3D, and 4D.
UNKNOWN 	 enables reading raw binary data into images, and 	

exporting image data as raw.
VolumeFile	 enables lists of 2D files to be used as a 3D entity
OBJMAP 	 enables object maps to be treated as regular images
ANALYZEIMG 	 old Analyze 7.5 format, i.e. .hdr & .img pairs
ANALYZESCRN 	 old Analyze 7.5 format of old Screen Edit program

Raster
BMP 	 Microsoft Windows Bitmap
GIF 	 a common color indexed format
JPG 	 common format featuring lossy compression
PBM 	 ascii and binary formats used in Portable Bitmap 

Library
PGM 	 grayscale Portable Bitmap Library
PPM 	 24 bit Color Protable Bitmap Library
PIC 	 format used by Softimage
PNG 	 Portable Network Graphics
PS 	 output to a PostScript raster dump
SGI 	 format used by Silicon Graphics
SUNRASTER 	 format used by Sun Microsystems
TARGA 	 a common color format
TIFF 	 tagged information file format, a common format
XBM 	 an ascii ‘c programming language’ format used by the 	

X Windows system
XWD 	 X Windows dump

Video
QUICKTIME 	 common movie format
YUV 	 single frame color video format
AVI 	 video format used by Microsoft Windows
MPEG1	 standard movie format

Standard Radiological File Formats
DICOM 	 the standard medical image file format based on 

Mallincrodt ctn_3_0_3.
ACR/NEMA 	 precursor to DICOM
PAPYRUS2 	 3D extensions to DICOM from OSIRIS
PAPYRUS3 	 3D extensions to DICOM from OSIRIS
NIfTI	 Neuroimaging file format

Vendor-Specific Radiological File Formats
GE9800 	 older CT format
GEADVANCE 	 Advance, nulcear medicine format
GEADVANTAGE	 format for CT and MRI
GESIGNA 	 older MRI format Signa 4.x
GESTARCAM 	 older PET format
INTERFILE 	 a standard format for nuclear medicine
PICKER MRI 	 old MRI format used by Picker
SIEMENSCT 	 old Siemens CT format Somatom DR3
SIEMENSMAGVIS 	 Siemens Magnetom Vision (MRI format)
CTI	 PET format used by CTI, early version of ECAT7
7CTI 	 PET format used by CTI; CTIECAT7
IMATRON 	 proprietary CT format
SMIS 	 proprietary MRI format
BRUCKER MRI	 proprietary MRI format
BIO RAD	 proprietary format
VARIAN FDF	 Varian MRI format

Supported File Formats

Exercise 3 : Switching on Support for Additional Formats
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Scanner acquired data is rarely isotropic (cubic) which means that the voxel width, height, and/or depth have different sizes (most often a different slice 
thickness than the in-plane resolution).  This exercise will demonstrate how to load an anisotropic (non-cubic) volume image with the same resolution as when 
acquired, and then load it again to resize the volume image to create an isotropically sampled volume (cubic) for further use in Analyze.

1.	 Open the Load As module (File > Load As).

2.	 Click File [A] and navigate to and select the MRI_Head.avw data set in the 
$:\BIR\images\TutorialData directory.

3.	 Uncheck the Auto Exit After Load option [B] and click Load.  The data will be loaded into 
the Analyze workspace as it was acquired (anisotropic).

4.	 To load the data as isotropic (cubic), select the Resize tab [C] (figure 1).

5.	 Check the Force Cubic option [D] and click Load; the data will be resampled at the cubic 
resolution and then loaded.  The highest spatial resolution in the acquired volume image is 
used as the cubic resolution for resampling.

6.	 Two volumes are now loaded into the Analyze workspace, ‘MRI_Head’ and ‘MRI_Head0’.  
The latter volume is the cubic volume.  To examine the effects of this isotropic sampling, 
proceed to Exercise 8: Multiplanar Sections.

7.	 If a specific cubic voxel resolution is desired, the voxel size can be changed.  To set the 
output voxel dimension to 1.5 mm, enter 1.5 in the Output Voxel Size field [E] and press 
<Enter>.  Notice that the ‘Output Axis Dimensions’ and ‘Memory’ fields automatically adjust 
when the voxel dimension is changed.

8.	 It is also possible to set a specific dimension for the resulting volume image.  For example, 
if you wanted an output volume with an X dimension of 200, enter 200 in the Output X Axis 
Dimension field [F] and press <Enter>.  Again, the other parameters will automatically 
adjust.

9.	 You may encounter data sets that are too large to be accommodated by the computer on 
which you are running (usually due to memory limitations), particularly at the resampled 
cubic resolution.  Specifying a maximum memory size while the Force Cubic option is 
checked forces each parameter to adjust to the largest value possible that still fits within the 
specified memory size.  Enter 16 into the Output Memory Mb field [G].

10.	 Close all windows related to the Load As module before proceeding to the next exercise.

Figure 1

Exercise 4 : Load As Loading and Resizing Anisotropic
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Occasionally it is necessary to import raw data or image data of an unknown file format into Analyze.  Such data can be imported if pixels are 
uncompressed and in contiguous images within the file.  The Raw Data tool provides several interactive options to view data as images, ASCII 
strings, or as the actual binary values of bytes and words.  Data can be directly loaded into Analyze or converted into Analyze format image files.  
Most image file formats consist of some initial header information describing the image(s) and the actual image data. This exercise will demonstrate 
how to convert raw data from a scanner, which currently has no direct file format support in Analyze.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Raw Data tool (Tools > Raw Data). 

3.	 With the Files tab selected, click the File button under ‘Input’ (figure 1).

4.	 In the Import/Export – Input File window returned navigate to the $:\BIR\
images\TutorialData\ImportExportTutorial directory and select the file 
UNKNOWN1.

5.	 Select the Image Parameters tab (figure 2). 

6.	 For this exercise, assume that we know that this file contains one 256 
x 256 image, a signed 16-bit integer.  An image of this size requires 
131072 bytes of storage (256 x 256 x 2), however the file size is 
137210 bytes.  This indicates that there is an additional 6138 bytes of 
header information present.  This needs to be skipped to get to the first 
byte of image data.  Finally, we know that the 16-bit image data in the 
file is stored in Big-Endian byte format.

7.	 To accommodate this, set the following parameters:   
•	 Byte Offset: 6138 [A](or check ‘Auto Offset’ to compute this 			 

automatically)
•	 Width: 256 [B]
•	 Height: 256 [C]
•	 Data Type: signed 16-bit [D]
•	 Byte Swap: Pairs (this only needs to be set on a little-endian 			

architecture, i.e., PC-based systems) [E]

Figure 1

Figure 2

Exercise 5 : Import/Export Converting Raw Data into Images
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8.	 Check the following Auto options [F]: 
•	 Display: Image display will update anytime a control parameter is 

changed.
•	 Clear: Image display is cleared before a new image is displayed.
•	 Scale: Data is automatically scaled from its entire dynamic range 

to 8-bits for display.

9.	 Click Display to view the current image in the main Import/Export 
window (figure 3).

10.	 Click Load in the Raw Data tool to load the image specified in the 
file into the Analyze workspace.  

11.	 Experiment with the display effects by changing the image 
parameters to incorrect values, use the up and down arrow buttons 
found next to the Width and Height fields.

12.	 Click Done to close the Raw Data tool. 

Figure 3

Exercise 5 : Import/Export Converting Raw Data into Images
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Most medical image formats do not support 3-D directly, since each slice in a study is written to a separate file.  The Volume Tool provides a way to 
create a pseudo format for handling groups of 2-D files as a single 3-D entity.  Analyze uses the AVW_VolumeFile, or volume file (.vol), as a way to 
organize a list of 2-D files into a 3-D volume.  The files must contain images of the same size and data type.  This exercise will show you how to use 
the Volume Tool to create a volume file from a list of 2-D TIFF files.

1.	 Open the Import/Export module (File > Import/Export).

2.	 Open the Volume Tool (Tools > Volume Tool).

3.	 In the Volume Tool, click Wild Cards.  

4.	 In the window returned (figure 1), click Directory and navigate to $:\BIR\images\
TutorialData\VolumeToolTutorial - the directory containing the 2-D TIFF data for this 
exercise. 

5.	 The Filter field is set to * by default so everything in the directory is selected.  As this 
directory only contains TIFF data specific to the data set we wish to load, leave the 
filter as is.  

6.	 Click Apply. The TIFF files will now be copied to the Volume Tool (figure 2).

7.	 In the Volume Tool, click Verify to ensure that all the slices selected are the same size 
and data type.  

8.	 A dialog box (figure 3) will be returned upon successful verification stating ‘Verify 
Succeeds’; click Continue.

9.	 Click Save and save the volume file as TIFF_Head.vol in the $:\BIR\images\
TutorialData directory.

10.	 Close the Import/Export module before proceeding to the next exercise. 

tip	 The volume file saved can now be loaded into Analyze 
using the Load or Load As modules. Alternatively you can 
load the volume file directly into the Analyze workspace 
from the Volume tool by clicking ‘Load’.

Figure 1

Figure 3 Figure 2

Exercise 6 : Import/Export Volume Tool
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At some point it will become necessary for you to save your data out of Analyze.  This exercise will demonstrate how to do this using the Save module.

1.	 Select a data set from the Analyze workspace.  If there is no data loaded, load MRI_
Head.avw from the $:\BIR\images\TutorialData directory.

2.	 Open the Save module (File > Save).

3.	 Click File and navigate to the directory where you would like to save the data set and 
specify a name.  Click Save to return to the main module window. 

4.	 Use the Format drop-down menu to specify the format in which you wish to save the 
data set.

5.	 Click Save to save the data set and close the Save module.

  tip	 You can also save your data out of Analyze using the Save As module.  The 
Save As module provides the same tools as the Load As module, allowing you to 
resize, change orientation, sub-region, and perform other manipulations on your 
data while saving it out of Analyze.

note	 Only formats enabled in the external libraries tool will be available. To switch 
on support for additional formats, please refer to Exercise 3: Switching on 
Support for Additional Formats.

Figure 1

Exercise 7 : Saving Data Out of Analyze
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Display &
Visualization

Analyze 10.0
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The Multiplanar Sections module allows the user to quickly and easily view image data in the plane of acquisition or in any naturally orthogonal 
plane.  The module contains several tools for easy two-dimensional display, and has the capacity to load volumes, load object maps, select 
orthogonal orientations, and perform intensity windowing or thresholding.

1.	 Load the MRI_Head.avw data set from the 
$:\BIR\images\TutorialData directory.  The data set may 
already be available in the Analyze workspace if you have 
completed exercise 4, Loading and Resizing Anisotropic Data.  

2.	 Open the Multiplanar Sections module (Display > 
Multiplanar Sections).

3.	 Press the Display Section(s) PowerBar button or choose 
Generate > Display Section(s).  This will begin a sequential 
display of the data, the display may be stopped at any time 
by clicking anywhere in the main Multiplanar Sections window 
(figure 1).  

4.	 Since MRI_Head.avw was acquired in the sagittal orientation, 
this is the default orientation for display purposes.  The display 
orientation can be changed to display images in a transverse, 
coronal, or sagittal orientation.  Use the Orientation PowerBar 
buttons to change the display orientation or open the 
Orientation window (Generate > Orientation).   

5.	 To specify a particular slice to view or to begin the sequential 
display from, open the Slice window (Generate > Slice).  Use 
the ‘Slice’ slider bar to set the specific slice. 

note	 Since MRI_Head.avw is anisotropic, images 
will appear “squashed” in the coronal and 
transverse orientations.  The resized data set 
MRI_Head0 created in exercise 4, Loading and 
Resizing Anisotropic data, will display normally 
in all three orientations.

  tip	 The Slice window also contains three display options: Continuous, Single 
Step, and Page Mode.  ‘Continuous’ sets the display mode to display the 
slices in a continuous stream.  ‘Single Step’ turns off the continuous display 
of slices, when Display Section(s) is selected only one slice is displayed.  
‘Page Mode’ sets the display mode to display a page of slices at a time when 
Display Section(s) is selected.

Figure 1

Exercise 8 : Multiplanar Sections
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6.	 The Scan Tool (Tools > Scan) provides an interface for slice-by-slice review.  Click 
either of the green ‘play’ arrows to start a sequential display of slices, or use the + 
and - buttons to move one slice at a time.  The slider bar can also be used to move 
through the slices.  

7.	 Open the Intersecting Sections tool (Tools > Intersecting Sections).  The 
Intersecting Sections tool provides an interactive display of intersecting orthogonal 
sections.

8.	 To change the angle at which the intersecting sections are viewed, use the View 
Angle X, Y, and Z slider bars [A].  The view angle can also be changed by clicking in 
the image display [B] and dragging the image to a new view.   

9.	 Use the Slice X, Y, and Z slider bars [C] to manipulate the intersecting orthogonal 
sections.  The ‘X’ slider bar controls the sagittal slice displayed, ‘Y’ the coronal, and 
‘Z’ the transverse; the slider bar and intersecting sections are also color-coded.  The 
image display will interactively update, allowing the user to navigate through the 
interior of the data set.

10.	 The scale of each plane can also be changed using the Scale X, Y, and Z slider bars.  
To increase the scale of all planes in proportion to each other, uncheck the Individual 
Axis option; one Scale slider bar [D] will replace the three slider bars, use this to 
increase and decrease the image size.  

11.	 Right-click on the image display and choose Auto Save.  Now, repeat some of the 
maneuvers described above; when you are finished, right-click again and uncheck 
the Auto Save option.  The maneuvers performed have been recorded and saved to 
the Analyze workspace.  The file can be reviewed with the Movie module (Display > 
Movie).

Figure 2

Intersecting Sections Tool

Scan Tool

Exercise 8 : Multiplanar Sections
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12.	 Open the Cube Sections Tool (Tools > Cube Sections).  The Cube Sections tool 
provides an interactive display of orthogonal sections in a three-dimensional viewing 
cube.

13.	 The View Angle [A] and Scale [B] options for the Cube Sections tool may be 
changed as described for the Intersecting Sections tool.  

14.	 Planes can be interactively sliced away in the three orthogonal orientations to revel 
interior sections of the cube with the Subregion X, Y, and Z double-ended slider bars 
[C].  As with the Intersecting Sections tool, ‘X’ controls the sagittal orientation slices 
displayed, ‘Y’ the coronal, and ‘Z’ the transverse; the slider bars and cube sides are 
also color-coded.

15.	 After subregioning the data set, right-click on the image display and choose Extract 
Sub-volume.  The subregioned data set will be saved to the Analyze workspace.

16.	 Click Done to close the Cube Sections tool.

17.	 Close the Multiplanar Sections module before proceeding to the Additional Task.

A

B C

Figure 3

Cube Sections Tool

Exercise 8 : Multiplanar Sections
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1.	 Select the MRI_3D_Head data set in the Analyze workspace and then open the 
Multiplanar Sections module (Display > Multiplanar Sections). 

2.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map 
from the $:\BIR\images\TutorialData directory.

3.	 When the object map loads the Objects window will automatically open 
(figure 1).  In the Objects window do the following: 
•	 Set ‘Control by’ to ‘Attribute’ 
•	 Set the Display of all objects to ‘On’ with the acceptation of the Original and 

Skin objects.

4.	 Open the Scan Tool (Tools > Scan) and use the slice slider to review the 
display of the image date (figure 2).

5.	 Open the Intensity option (View > Intensity). In the Intensities window, review 
each of the Object Color modes by selecting each from the ‘Mode’ drop down 
menu.
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1. Creating a Grayscale Data Set with Color Overlaid Objects

Windowed Object Local Max/Min Color EdgesObject Only Edges Only

Figure 1

Figure 2

Figure 3

The ability to create a grayscale image overlaid with colored objects, also known as an Intensified Volume, 
can be useful.  This exercise will demonstrate how to achieve this using the Multiplanar Sections module.  

Exercise 8 : Multiplanar Sections
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6.	 Change the ‘Mode’ back to ‘Windowed Object’.

7.	 Next select File > Output Intensified. A message will be returned (figure 4), 
select ‘Continue’.

8.	 A new Intensified Volume will be saved to the Analyze Workspace. 

9.	 Close the Multiplanar Sections module before proceeding to the next 
exercise.
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note	 If you have reviewed the data set using the Display Sections option, 
make sure you use the Generate > Slice option to set the slice 
number back to 1.

Figure 4

1. Creating a Grayscale Data Set with Color Overlaid Objects

Exercise 8 : Multiplanar Sections
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Sometimes a particular structure of interest within a data set is not aligned with the orthogonal axes of the 3-D volume.  The Oblique Sections 
module interactively generates any arbitrary plane through a data set and allows reformatting of a series or the entire data set.  This exercise will 
demonstrate how to create an obliquely resampled data set for further analysis with Analyze.

1.	 Load the Canine_Chest_CT.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Oblique Sections module (Display > Oblique Sections).

3.	 Open the Fly tool (Generate > Fly).  

4.	 Use the Fly tool (figure 1) to rotate the current oblique plane from the transverse 
orientation to the sagittal orientation: 

i.	 Click the Roll Right button [A] nine times to rotate the oblique plane into the 
sagittal orientation.  The Fly Value defaults to 10 [B], so for each selection of 
‘Roll Right’, the plane is rotated by 10 degrees (90 total).  

ii.	 Given that the view of this sagittal orientation is as if the body was in a prone 
position, click the Yaw Counter Clockwise button [C] nine times to rotate the 
body upright.  This is a right lateral view of the chest. 

iii.	 If a left lateral view is desired, click the Roll Left button [D] to complete a roll 
of the oblique plane by 180 degrees (select the button 18 times).  Note that the 
plane appears to rotate through the data set, passing from a right lateral view to 
a left lateral view. 

4.	 Reset the oblique plane to the central transverse slice by selecting the ‘T’ Cube at the 
bottom of the Fly tool [E].

tip	 The ‘Fly Value’ [B] can be changed to make incrementally larger or smaller 
changes when performing manipulations (e.g. set the ‘Fly Value’ to 180 and 
press ‘Roll Left’ once to rotate 180 degrees).

Figure 1

Exercise 9 : Oblique Sections Oblique Resizing of Volumes
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Exercise 9 : Oblique Sections - Oblique Resizing of Volumes

5.	 Open the Matrix Tool (Tools > Matrix) to display the current transformation matrix 
that reflects this 3-D orientation (figure 2). 

6.	 Now, complete the “fly” maneuvers as given above to rotate from the transverse 
orientation to the sagittal orientation again.  Note the changes in the transformation 
matrix in the Matrix tool as these maneuvers are carried out.  This demonstrates 
that the oblique plane manipulation is represented as a full 3-D transformation, with 
resampling of the data occurring based on the respective 3-D transformation as given 
in the matrix.

7.	 Use the Fly tool to select an arbitrary oblique orientation of your choice.  For example, 
click the Roll Right button three times, then the Yaw Clockwise button four times.

8.	 To save the data set in this oblique orientation, choose File > Output.  

9.	 In the Output window, set Destination to Workspace and change Name to xxx_
myoblique (where ‘xxx’ are your initials) (figure 3).  

10.	 To resample the entire data set, set Method to Reformat Entire Volume.  Since this 
is an oblique orientation, the resampling space for the new data set may need to be 
larger than the original, so by default the Change to best fit data option is selected to 
output a large enough data set to capture all transformed voxels.

11.	 Click Generate Slices.  The resampled data set is now saved to the Analyze 
workspace.

12.	 Close the Oblique Sections module before proceeding to the Additional Task.

13.	 To view your new reformatted data set, open it with the Multiplanar Sections module.

Figure 2

Figure 3
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1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Oblique Sections module (Display > Oblique Sections).

3.	 Open the Fly tool (Generate > Fly). Use the Fly tool to set the display orientation to Sagittal by clicking on the S-cube.

4.	 Next select Generate > Grid Align to apply the grid overlay to the current slice.

Translation:
•	 Click to select a point near the center of the grid axis (anywhere within the 36 center boxes). [A]
•	 While holding the mouse button down, move your cursor so that the center intersection of the grid is moved to the new 

desired location. In this example the middle of the cerebellum. [B]
•	 Release the mouse button. The image will be translated with the selected region as the new center point. [C] 

1. Grid Align Tool

The new Grid Align tools provides users with the ability to interactively reorientate image data using a gird overlay  on the current oblique 
slice, this allows for easy reorientation with reference to structures in the slice. The grid allows for reorientation via translation and yaw of the 
oblique slice. This task will demonstrate how to reorientate data using the tool.

Exercise 9 : Oblique Sections
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1. Grid Align Tool

5.	 Click on the S-Cube in the Fly tool to reset the image display.

Yaw:
•	 Click to select anywhere towards the outside of the grid (anywhere not within the 36 center boxes). [A]
•	 While holding the mouse button down, move your cursor to rotate the grid about the center axis. In this example, aligning a 

grid line along the brain stem. [B]
•	 Release the mouse button to apply the Yaw reorientation to the image. [C]

6.	 Close all Oblique Sections windows before proceeding to the next exercise.

Exercise 9 : Oblique Sections
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This exercise will review additional manual realignment tools available in the Oblique Sections module.  The exercise will explain how to use these 
tools by demonstrating how to realign the brain along the AC-PC.  Please note that the Mayo 3D Brain Atlas add-on provides an interactive AC-PC 
based alignment tool for realignment of volume image data to the Talairach-Tournoux coordinate and proportional grid system, for more information 
please review the Mayo 3D Brain Atlas exercise.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory. 
Then open the Oblique Sections module (Display > Oblique Sections).

2.	 Once the Oblique Sections module is open, select the Orthogonals 
(Tools > Orthogonals).

3.	 In the Orthogonals window (figure 1), move to the mid-sagittal slice 
where the AC and PC can be identified using the slider bar under the 
sagittal display pane [A]. It may be helpful to increase the display size 
of the sagittal slice. To do this, right-click on the pane and select the 
Size option [B].

4.	 At the bottom of the Orthogonal window, select the Interactive 
Perp Axis option [C] to turn on the interactive generation of the 
perpendicular axis and the perpendicular oblique.

5.	 Now, on the sagittal image, move your cursor to either the AC or PC points and select 
this point with your mouse button. Hold the mouse button down as you drag the line 
from this point to the other AC or PC point. Release the mouse button when the other 
point has been selected [D].

6.	 This provides the AC-PC axis and generates an oblique image, which is perpendicular 
to the midpoint of this axis - essentially a coronal image.

7.	 The Perpendicular Axis window automatically opens (figure 2). This will allow you to 
note the coordinates of the AC and PC points (Point 1 and Point 2) if desired.

8.	 Open the Fly tool from the Generate menu in the main Oblique Sections window 
(Generate > Fly).

Figure 1

Figure 2

Exercise 10 : Oblique Sections Manual AC-PC Realignment
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9.	 Change the Fly Value to 90 (figure 3), and do a Pitch maneuver. This 90 degree pitch 
places the current oblique image in the plane of the AC-PC line.

10.	 Now change the Fly Value to a smaller value (e.g. 1 to 5 degrees).

11.	 Viewing the main oblique image, you can use the Roll and Yaw maneuvers to attempt 
to accommodate brain symmetry in this oblique plane. This is an entirely visual process 
and shouldn’t require much manipulation. Note that you may have to do other smaller 
manipulations along the way to adjust for the volume being tilted slightly, but you can do 
this at any time.

12.	 When satisfied with this ‘transverse-oblique’ along the AC-PC plane, select File > 
Output.

13.	 Change the Method to Reformat Entire Volume to generate the output volume at 
this new orientation. It is up to you to reformat this back into the original volume size 
(Maintained), or new output volume that can hold the entire span of the rotated original 
volume (Change to best fit data).

14.	 Select Generate Slices to save the AC-PC aligned volume to the Analyze workspace.

15.	 Close the Oblique Sections module before proceeding to the next exercise.

note	 The anterior part of the brain should be at the top of the oblique image. If 
it is not, then you can do two more 90 degree pitch maneuvers to flip this 
oblique plane around 180 degrees.

Figure 3

Figure 4

Exercise 10 : Oblique Sections Manual AC-PC Realignment



Analyze 10.0 Essential Training Guide 42

The Volume Compare module provides the ability to compare data sets images that have the same spatial resolution. This exercise will provide an 
overview of the module.

1.	 Load the MRI_3D_Head.avw and MRI_3D_Brain.avw data sets from the $:\BIR\
images\TutorialData directory. Select both data sets, MRI_3D_Head.avw first and 
MRI_3D_Brain.avw second. 

2.	 Open the Volume Compare module (Display > Volume Compare).

3.	 Open the Blend window, select Yellow-Cyan. Click on any of the images and drag 
your cursor to move through the image display. Alternatively, use the arrow keys and 
the page up, page down keys to move through the data.

4.	 From the File menu, select Load First Object Map and load the MRI_3D_Head.obj.

5.	 Next, load the MRI_3D_Brain.obj object map for the second volume (File > Load 
Second Object Map).

6.	 Use the crosshairs to navigate through the data (figure 2).

7.	 Double click in any pane to log points. To save the Point Log, click 
Save (figure 3).

8.	 To save the Fused Volume, select File > Save Fused.

9.	 Close the Volume Compare module before proceeding to the next 
exercise.

Figure 1

Figure 2Figure 3

Exercise 11 : Volume Compare
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The Volume Render module provides a variety of display representations for three-dimensional image data sets.  Also provided in the module are tools for 
volume image editing and measurement.   This exercise will demonstrate the different control parameters involved in the process of volume rendering.  This 
includes demonstrating various rendering algorithms that are part of the suite of techniques used to render volume images with Analyze.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Press the Render PowerBar button or choose Generate > Render. 

4.	 Open the Preview window (Generate > Preview).  

5.	 Open the Thresholds window (Generate > Thresholds).  

6.	 Set the Threshold Minimum to 85 (figure 1) - all voxels with a value less than 85 are 
now removed from view.  

7.	 The resulting image can be seen in the Preview window (figure 2).  Click Render to 
display the rendering in the main Volume Render window.

8.	 Now, set the Threshold Minimum to 145—all voxels with a value less than 145 are 
now removed from view.  Click Render.  

9.	 Open the Rotation window (Generate > Rotation).  

10.	 The Volume Absolute option is selected by default (figure 3); use the X, Y, and Z 
slider bars to change the rendering view.  Click Render as desired. 

11.	 Select the Screen Relative and Volume Relative options and compare the different 
rotation methods available.  The ‘Screen Relative’ option specifies that the rotation 
of the volume be performed relative to the current screen axis, while the ‘Volume 

Figure 2

Figure 3

Figure 1

Thresholding Data

Controlling the Rotation Parameters

Exercise 12 : Volume Render Basic Rendering Controls
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Relative’ option specifies that the rotation be performed relative to the current position 
of the volume axis.

12.	 Look at the Matrix option, but adjustment is not recommended. 

13.	 Experiment with the Named option views.

14.	 Select the Change View option and use the arrows to manipulate the rendering view 
(figure 4).  Alternatively, you can click and drag the rendering to a new angle in the 
image display.

15.	 When you are familiar with all of the rotation options, select the Front view from the 
Named option and click Render.  

16.	 Click Done to dismiss the Rotation window.

17.	 Open the Render Types window (Generate > Render Type) (figure 5).

18.	 Experiment with the rendering algorithms.  (See Note below).

19.	 Select the Depth Shading option.  View the rendering in the Preview window.  Click 
Render to display the rendering in the main Volume Render window (figure 6).

20.	 Select the Volume Compositing option.  View the rendering in the Preview window.  
Click Render to display the rendering in the main Volume Render window (figure 7).  
For more information on the Volume Compositing Tissue Map Type Specific option, 
please review exercise 13, Volume Render – Tissue Map Tool.

note	 As the rendering is moved, only the originally viewable voxels are interactively re-
rendered, providing visual cues to the movement and orientation of the image.  Upon 
release of the mouse button, the full image is rendered at the new orientation.

note	 Additional parameters for each render type are available from the Type Specific 
sub-menu (Generate > Type Specific), explanation of all of these additional 
options is beyond the scope of this exercise, but more information can be found 
in the User’s Guide (Help > User’s Guide). 

Figure 4

Figure 6

Figure 7

Figure 5

Rendering Algorithms

Exercise 12 : Volume Render Basics
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21.	 Select the Maximum Intensity Projection option.  Click Render to display the 
rendering in the main Volume Render window.  

•	 This render type is normally used with vascular data where the signal is enhanced
 (usually using contrast), but the dense bone in this data set also shows up well.  
Try the MIP Weighting option available from with the Type Specific sub-menu 
(Generate > Type Specific > MIP Weighting).  The ‘Before’ weighting option 
works very well with this input data (figure 8).

22.	 Select the Summed Voxel Projection option and click Render.  

•	 If the threshold minimum is still set to 145, the Summed Voxel Projection algorithm 
is actually only adding and averaging the voxels corresponding to bone, ignoring 
all soft tissue.  In most cases, whenever you use the Summed Voxel or Maximum 
Intensity Projections render types, you may want to set the threshold range to the 
complete range of the input data.  

•	 In the Thresholds window (Generate > Thresholds) change the Threshold 
Minimum to 0 and click Render.  Notice that now the Summed Voxel Projection 
rendering looks like a re-projection X-ray (a Digitally Reconstructed Radiograph – 
DRR) (figure 9).

23.	 Select the Surface Projection option.  Set the Threshold Minimum back to 145 in 
the Thresholds window, then click Render.  This render type is more effective with 
different input data, but the effect can be seen using the current surface (figure 10).

24.	 Select Gradient Shading and click Done to dismiss the Render Types window.

25.	 Open the Clip tool (Generate > Clip).  

26.	 The Clip tool (figure 11) allows a subregion of the volume to be rendered.  Experiment 
with the Clip Plane and Clip Volume parameters.

27.	 Click Done to close the Clip tool.

28.	 Close all windows related to the Volume Render module before moving onto the next 
exercise.

note	 When working with anisotropic 
data, the ‘Interpolated Rays’ 
option may help to improve the 
quality of the rendering. 

Figure 9 Figure 10

Figure 11

Figure 12

Figure 8

The Clip Tool
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Adding the ability to control specific objects in the rendering process provides incredible power and versatility in the creation of unique visualizations.  
In Analyze, this is possible with the use of object maps.  Object maps are special image files that are used in Analyze to partition and identify 
structures as belonging to a particular segmented object.  Voxels in the volume image correspond directly, on a one-to-one basis, with a voxel in 
the object map, whose value assigns the voxel to a particular segmented object.  Each of the objects within the object map can be controlled and 
manipulated independently.  This exercise will begin to explore the power of object control in creating 3-D visualizations, but will only “scratch the 
surface” of the endless possibilities for exploration of this 3-D visualization space.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.  

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Choose File > Create Object Map.  The Objects window will automatically be 
returned; dismiss the window for now by clicking Done.

4.	 Open the Threshold Tool (Tools > Manipulate > Threshold) (figure 1).
•	 Set the Minimum Threshold to 85 [A].  
•	 Set Change to Object Map [B].  
•	 Set Defined Object to ***New*** [C]. 
•	 Click Threshold Volume to define a new object.  Note all voxels from 85 to 255 will 

be defined as a new object, ‘Object_2’.  
•	 Click Done to close the Threshold Tool.

5.	 Open the Preview window (Generate > Preview) to interactively review your changes.

6.	 Open the Objects window (View > Objects).  Select Object _2 (if it is not already 
selected) from the Object drop-down menu.  Change the following attributes for 
Object_2:

7.	 Click Render to display the rendering in the main Volume Render window (figure 2).

8.	 In the main Volume Render window, open the Thresholds window (Generate > 
Thresholds).  Set the Threshold Minimum to 145 and click Render. 

Figure 1

Figure 2

Defining Objects in an Object Map

Exercise 13 : Volume Render Advanced Rendering Controls
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  tip	 Up to 255 different 
objects can be 
defined in an 
object map.

9.	 Open the Connect Tool (Tools > Manipulate > Connect). 
•	 Change the Connect Method to Connected Components.  
•	 Set to Keep the ‘3’ Largest Objects. 
•	 Click Label Components.  The three largest objects will automatically be identified 

and labeled as new objects (figure 3).
•	 Click Done to close the Connect Tool.

10.	 In the Objects window (View > Objects) (figure 4), click Reassign Object(s) [A].  

11.	 In the window returned (figure 5), select: BlueObject from the Reassign from list. 
From the drop down menu to the right select: YellowObject.  Click Apply and then 
OK to dismiss the window.  Note the update in the Preview window.

12.	 Click Remove Unused [B] in the Objects window to remove ‘BlueObject’.  Click OK 
in the dialog box returned.  

13.	 Select the GreenObject from the Object drop-down menu.  Then change the 
following attributes:
•	 Name: Bone
•	 Color: white
•	 Shades: 32

14.	 Select the YellowObject from the Object drop-down menu.  Then change the 
following attributes:
•	 Name: Rope
•	 Color: red
•	 Shades: 8

15.	 Click Render.  

16.	 In the Thresholds window (Generate > Thresholds), set the 
Threshold Minimum to 5.  

17.	 Return to the Objects window and set Control by to Attribute [C].  

Figure 3

Figure 4

Figure 5

Manipulating Objects

Exercise 13 : Volume Render Advanced
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18.	 Set the Display attribute to Off for the Original object.  Then, click Render.  

19.	 Open the Render Types window (Generate > Render Type).  Select the Object 
Compositing option, then open the Object Mapping window, (Generate > Type 
Specific > Object Mapping). 

20.	 Select the Transparency render type (figure 6) and click Render to view the effects.  

21.	 A variety of object attributes can be controlled in the Objects window.  Set Attribute 
to Opacity by selecting it from the drop-down menu.  Change the Bone object to 1 
(opaque).  Click Render (figure 7).

22.	 Object maps can be saved for review or use at a later time, or to load into another 
Analyze module; choose File > Save Object Map to save the object map.  

23.	 Name the file Cubic_CT_Head_xxx.obj (where ‘xxx’ are your initials) and specify a 
location to save the file, then click Save (object maps are saved as .obj files).

24.	 Close the Volume Render module before proceeding to the next exercise.

note	 The Object Mapping is only available if the Object 
Compositing option is selected. The Transparency 
render type is only available when an object map 
has been loaded or created. 

Figure 6

Figure 7

Saving an Object Map
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The Tissue Map tool provides a control interface that allows for the creation of unique visualizations.  This exercise will demonstrate how to use the 
tool to generate visualizations of different tissues.

1.	 Load the CT_Heart.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Open the Render Types window (Generate > Render Type). 

4.	 Select the Volume Compositing render type (figure 1).  Click Render, then click 
Done to dismiss the window.

5.	 Open the Tissue Map tool (Generate > Type Specific > Tissue Map).

6.	 A tissue map is a mapping of the voxel values within a volume to a given color and 
opacity.  The Tissue Map tool provides several control options to aide in the creation 
of a tissue map for a volume.  

7.	 The Tissue Map tool provides four control “points” to 
manipulate which voxel values are mapped to specific 
colors and opacity (figure 2).
•	 Start [A]: The starting voxel value within the volume 

mapped to a specific color (chosen from the color 
drop-down menu) with 0% opacity.

•	 Min [B]: The minimum voxel value within the volume 
that will be mapped to a specific color and set 
opacity (e.g. 44%).

•	 Max [C]: The maximum voxel value within the 
volume that will be mapped to a specific color and 
set opacity (e.g. 44%).

•	 End [D]: The ending voxel value within the volume 
mapped to a specific color with 0% opacity. 

8.	 Click Render to view the rendering with the default 
parameters (displayed in the main Volume Render 
window).  

	 The Tissue Map tool is only 
available with the Volume 
Compositing render type

Figure 1

Figure 2

Exercise 14 : Volume Render Tissue Map Tool
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9.	 Use the slider bars [A] in the Tissue Map tool to set the 
following (figure 3):
•	 Start: 157
•	 Min: 200
•	 Max: 500
•	 End: 3072

10.	 Select 60 from the Opacity drop-down menu [B].  Click 
Render to view the effect of the changes (figure 4).

11.	 Now, experiment by moving the control points in the 
graphical display [C].  Click Render as desired.

12.	 Right-click in the graphical display and select Show 
Histogram; the volume histogram will be calculated 
and displayed.  This option may help determine voxel 
values associated with tissues.

13.	 Several default tissue maps are also available, right-
click in the graphical display and choose Default 
Tissue Maps > CT1; once loaded, click Render
(figure 5). 

14.	 Experiment with adding a second tissue to the tissue map by clicking the + button [D] 
to the right of the graphical display.  Click Render as desired to see the effect. 

15.	 Close the Volume Render module before proceeding to the next exercise. 

Figure 3

Figure 5Figure 4

Exercise 14 : Volume Render Tissue Map
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The Volume Render module contains a number of tools for movie generation.  This exercise will introduce the Sequence tool.  While complicated 
movies can be created, the goal of this exercise is to demonstrate how to generate a quick, simple movie.  For more information, please review the 
Movie Making with Volume Render Tutorial after you have completed this exercise.  The tutorial can be accessed from the Help menu in the main 
Analyze workspace. 

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.  

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Choose File > Save Renderings (figure 1).  

4.	 In the Save Renderings window, check the Save After Each Render option and 
change Name to MyTestMovie.  The movie that is generated will automatically be 
saved to the Analyze workspace as ‘MyTestMovie’.  

5.	 Click Done to dismiss the Save Renderings window.  

6.	 Open the Sequence tool (Generate > Sequence).

7.	 By default, the ‘sequence’ already has one action, ‘Z Rotation’.  To modify the action 
click Modify [A], and then click on the red ‘Z Rotation’ action [B] (figure 2).  The 
Action window will automatically be returned.

8.	 For the first part of this movie, we will threshold the data set to show the structure 
of interest, in this case the head.  If you have completed Volume Render exercises 
11 and 12, you will know that in order to view the head in this data set, we need to 
increase the threshold minimum to 85.  

9.	 In the Action window, set the following parameters (figure 3):
•	 Action Name: Threshold
•	 Number of Frames: 36, the default frame display is 12 frames per second. 
•	 Persistent: Checking the ‘Persistent’ option will ensure that the minimum threshold 

parameter set in this action will be retained for the rest of the movie.  If not 
checked, the threshold minimum will be reset after the action is completed. 

•	 Parameter: Threshold
•	 End Minimum: 85

Figure 1

Figure 2

Figure 3

Exercise 15 : Volume Render Movie Making with the Sequence Tool
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10.	 To preview the movie with the new action, first open the Preview window (Generate > 
Preview).

11.	 Now, in the Sequence tool, click Sequence [C].  Then, click Make Sequence [D] 
(figure 4).

12.	 A dialog box will be returned asking if you would like to ‘Preview’ or ‘Make the 
Sequence’, click Preview the Sequence.  The movie will now be played in the 
Preview window.

 

13.	 Add another action to the movie.  Click Add Action [E] and place the new action on 
Track 2 in Frame 36 [F]; this will be directly under the last frame of the ‘Threshold’ 
action (figure 5).

14.	 Once the new action has been added, click Modify [G] and then click on the new 
action to open the Action window.

15.	 We will now add a rotation to the movie.  Set the following parameters for the new 
action:
•	 Action Name: Rotation
•	 Number of Frames: 60  
•	 Parameter: Rotation
•	 End Z: 720 (2 rotations, 360=1 rotation)

16.	 Click Done to dismiss the window.

17.	 Review the movie.  Click Sequence, and then, with the Preview window open, click 
Make Sequence.  

18.	 In the dialog box returned, click Preview the Sequence.  The movie playing in the 
Preview window should show the data set being thresholded to the head, followed by 
two quick rotations about the Z-axis.

note	 The ‘Preview the Sequence’ option is only available when the Preview 
window is open.  If the Preview window is not open, the dialog box will 
not be returned after clicking ‘Make Sequence’, instead the sequence will 
automatically be generated.

tip	 To slow the rotation of the data set, simply 
add more frames in the Action window 
(e.g. Change Number of Frames from 
60 to 120), or only show one rotation by 
changing the End Z value to 360 from 720.

Figure 4

Figure 5
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19.	 To generate the movie, click Sequence again.  This time, after clicking Make 
Sequence, choose Make the Sequence from the dialog box returned.

20.	 As the sequence is generated, each frame will be displayed in the main Volume 
Render window.  Each frame is also being written to a movie file called ‘MyTestMovie’ 
in the Analyze workspace (specified earlier in the Save Renderings window).  

21.	 Once sequence generation is complete, close the Volume Render module.  

22.	 In the Analyze workspace, select the MyTestMovie file and review it using the Movie 
module (Display > Movie). (figure 6)

23.	 To save the movie out of Analyze, choose File > Save in the Analyze window.  
Choose a movie file format (AVI, QuickTime, or AnimatedGIF) from the Format drop-
down menu before clicking Save.  

24.	 Close the Movie module before proceeding to the next exercise.

Figure 6

Exercise 15 : Volume Render Sequence Tool
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The Fix Tool provides the capability to correct for bad slices within a volume. The tool allows a variety of correction methods for missing or corrupt 
images that occur in a volume, including removing corrupt images, copying from an adjacent uncorrupted image, and interpolation from a range of 
uncorrupted images near the corrupt image.  This exercise will demonstrate how to use the Fix Tool to correct for bad slices within a volume.

1.	 Load the VH_Abdomen.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Open the Preview window (Generate > Preview).  

4.	 Now, open the Thresholds window (Generate > Thresholds). 

5.	 Set the Threshold Minimum to 26; the Preview window will interactively update 
(figure 1).  Note the lines that appear in the image [A].

6.	 Open the Ortho Sections tool (Tools > Display > Ortho Sections). 

7.	 In the Ortho Sections tool (figure 2), click on the line in the 
rendering seen in the top left pane [B].  The three orthogonal 
views will automatically update.  Notice the corrupt image in the 
transverse orientation [C]. 

8.	 Click Done to close the Ortho Sections tool.  Also close the 
Thresholds and Preview windows. 

Figure 1

Figure 2
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9.	 Open the Fix Tool (Tools > Manipulate > Fix).  

10.	 In the Fix Tool (figure 3), use the Displayed Slice slider bar [D] to locate the first 
corrupt slice.  Note that the first corrupt slice is slice 276.  

11.	 In the Bad Slice(s) portion of the window, set slice 276 as the first bad slice [E]. 

12.	 Now, use the Displayed Slice slider bar to locate the last corrupt slice.  Note: the last 
corrupt slice is slice 279.  

13.	 In the Bad Slice(s) portion of the window, set slice 279 as the last bad slice [F].

14.	 Select Interpolate Between the First Good Slice for the correction method [G].

15.	 Click Fix Slice(s).  A dialog box will be returned, click Change a Copy of the Loaded 
Volume.  The fix will now be applied to a copy of the data set; the fixed data set will 
be saved to the Analyze workspace as ‘VH_Abdomen0’.

16.	 Click Done to close the Fix Tool.  

17.	 In the main Volume Render window, press the Render PowerBar button or choose 
(Generate > Render).  Note that the lines that appeared in the top of the image are 
no longer present (figure 4).  

18.	 Close the Volume Render module before proceeding to the additional task.

note	 This method uses linear interpolation to calculate a replacement slice for each 
bad slice.  The value of each voxel is computed using information for each of the 
good slices on each side of the bad slices.  The percentage of each image used is 
calculated based on the distance from the bad slice to each good slice.

Figure 3

Figure 4
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1.	 Select the VH_Abdomen data set in the Analyze workspace and open the 
Volume Render module (Display > Volume Render).

2.	 In the main Volume Render window, choose File > Input/Output Ports.  
The VH_Abdomen data set icon will appear under the ‘Volume’ port.   

3.	 In the Analyze workspace, select the fixed data set created in the main 
exercise, VH_Abdomen0.

4.	 Drag-and-drop VH_Abdomen0 to the Related Volume port in the main 
Volume Render window (figure 5).

5.	 Open the Fix Tool (Tools > Manipulate > Fix).

6.	 As in the main exercise, set slice 276 as the first bad slice and slice 279 
as the last bad slice.

7.	 Select Copy from Related Volume for the correction method.

8.	 Click Fix Slice(s).  Slices 276 through 279 will be copied from the related 
volume and replace the corrupt slices in the loaded volume.  A dialog box 
will be returned, click Change a Copy of the Loaded Volume.  

9.	 Click Done to close the Fix Tool.  

10.	 In the main Volume Render window, press the Render PowerBar button or 
choose Generate > Render.  Note that the lines that appeared in the top of 
the image are no longer present (see step 7 in the main exercise).  

11.	 Close the Volume Render module before proceeding to the next exercise.

Figure 1

The option ‘Copy from Related Volume’ provides the ability to use a related volume as input for the Fix Tool, allowing images to be copied 
from the Related Volume to the Loaded Volume.  To demonstrate the new fix option we will correct for the corrupt slices in the ‘VH_Abdomen’ 
data set, using the fixed slices from the ‘VH_Abdomen0’ data set.
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The Volume Render Merge Tool allows images generated with different render types to be merged into a single image providing users with the ability 
to create unique visualizations of their image data.  This exercise will demonstrate how to use the Merge Tool to create a unique rendering of the 
brain and ventricles. 

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Choose File > Load Object Map and load the MRI_ 3D_Head.obj object map from 
the $:\BIR\images\TutorialData directory.

4.	 Open the Preview window (Generate > Preview)

5.	 Open the Rotation window (Generate > Rotation).  In the Rotation window select 
Named and then select Right.  Note that after this point you will not be able to 
reposition the data.

6.	 Open the Objects window (View > Objects) and set the ‘Control by’ option to 
‘Attribute’.  Set the Display attribute to Off for all objects except the Ventricle 
(figure 1).

7.	 Next we will use some of the additional rendering options to generate a rendering 
of the ventricle. Open the Specular Reflection tool and Light tool from the Type 
Specific menu (Generate > Type Specific > ). 

8.	 In the Specular Reflection tool set the following parameters (figure 2):
•	 Specular Reflection to On
•	 Factor to 0.32
•	 Exponent to 0.1

9.	 Use the Light tool to brighten the image display by moving the Brightness slider to 
the right (figure 3). 

10.	 Once these parameters are set, click the Render button in the main Volume Render 
window.

Creating the First Image

Figure 1

Figure 3

Figure 2

Exercise 17 : Volume Render Creating a Merged Image
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11.	 Next open the Merge tool from the Tools menu (Tools > Display > Merge).

12.	 The current rendering will be displayed in the ‘Current’ port. Click the ‘Current to 
Previous’ button to copy the current rendering over to the ‘Previous’ port (figure 4). 

13.	 In the Objects window, switch the display of the Ventricle to Off and the display of 
the Brain to On. Next, change the Attribute from Display to Color and change the 
Brain color from Pink to White (figure 5).

14.	 Open the Render Type window (Generate > Render Type) and set the Render Type 
to Surface Projection (figure 6).

15.	 Next, open the Surface option from the Generate > Type Specific menu. In the 
Surface option set Skip to 2 and Thickness to 6 (figure 7). Note the display of the 
brain from the Preview window. 

16.	 Once these parameters have been set, click on the Render button in the main Volume 
Render workspace.

17.	 The ‘Current’ rendering in the Merge Tool will update. 

18.	 Right-click on the main image display window in the Merge Tool, set the Merge Type 
to Average (figure 8). Note the updated display. Right-click and set the Merge Type 
back to ZBuffer Depth.

note	 If you wish to return to this point at a later time, save the rendering by right-
clicking in the ‘Previous’ port and select the ‘Save Previous’ option.

Creating the Second Image

Merging the Images

Figure 4

Figure 5

Figure 6

Figure 7

Figure 8
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19.	 Decrease the ‘Opacity’ value of the current rendering by moving the Opacity slider bar 
under the current rendering to the left. An Opacity of 0.32 works well (figure 9).

20.	 Next, click the ‘Merge to Current’ button.

21.	 To save the rendering, select File > Save Renderings. In the Save Renderings 
window, change the Name to ‘Merged Image’ and then click on the ‘Save Last 
Rendering’ button.

22.	 The following window may be displayed (depending upon the render options you set). 

23.	 Select the ‘Intensity Scaled (unsigned 8-bit)’ option. The rendering will be saved to 
the Analyze workspace and can be saved out of Analyze as a .jpg, .tiff, or .bmp using 
the Save module.

24.	 Close the Volume Render module before proceeding to the next exercise.

Figure 9

Exercise 17 : Volume Render Merge Tool
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1.	 Load the CT_Heart.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Volume Render module (Display > Volume Render).

3.	 Open the Render Size option from the Generate menu and change the Width and 
Height of the Render size to 2000x2000. Then click Apply (figure 1).

4.	 Open the Render Type window from the Generate menu and select Volumetric 
Compositing, check the Interpolated Rays option (figure 2).

5.	 Open the Tissue Map tool (Generate > Type Specific > Tissue Map). Right-click 
on the main tissue map panel and select Load Tissue Map, choose the CT 2 default 
tissue map.

6.	 Now open the Perspective Rendering tool (Tools > Display > Perspective) and 
then click the Perspective Render button (figure 3). In Perspective mode, a ray is 
cast for every output pixel in the rendering. In this case 4 million (2000x2000) rays are 
cast through the current field of view (FOV) for the perspective geometry.

7.	 Note the Render Size controls the number of rays, and the FOV controls the space in 
the volume through which that number of rays is cast. It may 
take a little while to render depending on the volume size.

8.	 Once the rendering is complete, the HDVR will be displayed 
in the main Volume Render window.

9.	 To save the rendering, Select File > Save Rendering. 
Name the rendering HDVR and then click the Save Last 
Rendering button.

10.	 Close the Volume Render module before proceeding to the 
next exercise.

The Volume Render module allows for the generation of High Definition Volume Renderings.  This exercise will demonstrate how to generate a high 
definition volume rendering using a CT data set with a Volume Composite with a tissue map overlay.  Note the high definition volume renders can be 
generated with any of the rendering algorithms available in the Volume Render module.

Figure 1
Figure 2

Figure 3

Exercise 18 : Volume Render Creating A High Definition Volume Rendering
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1.	 Load the SISCOM_Extracted_Brain.avw and SISCOM_4D_ActivityMap.avw data 
set from the $:\BIR\images\TutorialData\AdditionalData directory.

2.	 Open the Volume Render module (Display > Volume Render). In the Volume 
Render window, select File > Input/Output Ports (figure 1).

3.	 Drag-and-drop the SISCOM_Extracted_Brain file from the Analyze workspace 
into the Volume port. Next, drag-and-drop the SISCOM_4D_ActivityMap from the 
Analyze workspace into the Related Volume port.

4.	 Open the Preview window (Generate > Preview).

5.	 Open the Parametric Mapping window (Generate > Type 
Specific > Parametric Mapping). 

6.	 In the Parametric Mapping window, set Parametric Mapping to 
On (figure 2).

7.	 Review the rendering in the Preview window. If necessary, use the 
Rotation window (Generate > Rotation) ‘Change View’ option to 
maneuver the brain to a desirable orientation (figure 3).

Volume Render provides the ability to generate parametric maps when a related volume is loaded and the render type is set to gradient shading. 
This exercise will demonstrate how to sue the parametric mapping option.

note	 The SISCOM_4D_ActivityMap is a multivolume created using the SISCOM module. 
Each volume represents an activation map generated with a different activity 
standard deviation. Starting at 0.1 and increasing at a 0.1 intervals to 5.0

Figure 1

Figure 2

Figure 3

Exercise 19 : Volume Render Parametric Mapping
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8.	 Review the effects of changing the Mapping Factor and Map 
Transparency options in the Parametric Mapping interactively in the 
Preview window.

9.	 To view the 4D multivolume over time, use the Which Mapping Volume 
option. Check Increment after each Render, then press Render, until 
you’ve made your way through the volumes (figure 4).

10.	 Close the Volume Render module before proceeding to the next exercise.

Figure 4

Exercise 19 : Volume Render Parametric Mapping
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Surface Render provides a semi-automated interface for the conversion of object maps into surface maps using the Adapt/Deform algorithm.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Surface Render module (Display > Surface Render).

3.	 Choose File > Load Object Map and load the Cubic_CT_Head object map from 
the $:\BIR\images\TutorialData directory.  The Objects window (View > Objects) will 
automatically be returned.  

4.	 In the Objects window, set Control by to Attribute and set the Display attribute to 
Off for the Rope, Left Skin, and Skull objects (figure 1).

5.	 Choose File > Create Surface Map.  The Surfaces window (View > Surfaces) will 
automatically be returned. 

6.	 In the Surfaces window, click From Object(s).  A dialog box will be returned asking 
if you would like to create the surface map from all currently active objects, click Yes.  
The objects that have their ‘Display’ attribute set to ‘On’ (in the Objects window) will be 
tiled and a surface map generated.

7.	 Once the surface map is generated, click Render to display the results (figure 2).

8.	 Choose File > Load Surface Map and load the Cubic_CT_Head.smp surface map 
from the $:\BIR\images\TutorialData directory.  

9.	 Click Render to display the results.

10.	 Open the Camera tool (Generate > Camera) and set Sort to Front-Back
(figure 3).  Click Render to display the results.

11.	 In the Surfaces window set Control by to Attribute.  Choose Shading from the 
Attribute drop-down menu and change the shading of the Right Skin surface to 
Gouraud.

note	 Where possible, the attributes of the surfaces in the surface map and 
the objects in the object map should have equivalent values.

Figure 1

Figure 2

Figure 3

Exercise 20 : Surface Render Surface Map Creation and Display
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1.	 Open the Preview window (Generate > Preview) to view changes prior to rendering.

2.	 In the Camera tool (Generate > Camera), set FOV to 60.

3.	 In the Surfaces window (View > Surfaces) select Display from the Attribute drop-
down menu and set the Rope, Right Skin, and Left Skin surfaces to Off.

4.	 Choose Transparency from the Attribute drop-down menu, and set the Skull and 
Jawbone surfaces to 1.0.  Click Render.

5.	 Open the Rotation window (Generate > Rotation).  

6.	 With the Volume Absolute option selected, set X: -64, Y: -3, Z: 37.  Then, click Render.

7.	 In the Camera tool select the Position option and set the Z position to –300.  Click 
Render and note the changes in the rendering.

8.	 Now, set the Position coordinates to X: 12, Y: 41, Z: -215.  Click Render and note the 
changes in the rendering (figure 5).

9.	 In the Rotation window, select the Change View option.  Use the arrow buttons or click 
and drag the rendering to a new view in the image display.  

10.	 Notice that each time the view is modified the image is re-rendered in the main module 
window.  To prevent this, right-click on the ‘Change View’ image display and deselect 
Regenerate on Release. 

11.	 Close all windows related to the module before proceeding to the next exercise.
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1. Advanced Visualization

12.	 Click Render, note the changes in the rendering (figure 4).  Experiment with the 
different shading options.

13.	 Choose File > Save Surface Map to save changes made to the surface map.  

14.	 If you wish to export the surface map out of Analyze for use in another application, 
choose File > Export Surface Map.  Surface maps can be exported out of the Surface 
Render module in the Inventor (.iv) or VRML (.vrml) surface description formats.  

15.	 To learn about more surface rendering tools and options, complete the Additional Task. 
Figure 4

Figure 5

Exercise 20 : Surface Render Surface Map Creation and Display
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Virtual Endoscopy is an important visualization application that results from the ability to create 3-D visualizations from a viewpoint inside of the body.  
This exercise will familiarize you with the Virtual Endoscopy module, demonstrating basic functionality and various methods of controlling the view. 

tip	 The ‘Eye’ position advances 
toward the selected point 
based on settings in the 
View Parameters window.

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual Endoscopy). 

3.	 Position the cursor on the image display near the center of 
the trachea (the hole in the flat surface) and click once; this 
will be set as the new ‘Look At’ point and the ‘Eye’ position 
will advance (figure 1).

4.	 Position the cursor on the flat surface outside of the trachea and click once.

5.	 The ‘Back’ PowerBar button can be used to reposition to previous locations; the 
‘Forward’ PowerBar button will move to the next location if one has been defined.  Press 
the Back button once.  

6.	 Position the cursor over the center of the trachea and click several times to navigate into 
the trachea.  Then, press the Back button until you return to the starting location.  

7.	 Open the View Parameters window (Generate > View Parameters). 

8.	 Set the Move Percent to 50.  Now, click again on the image display near the center of 
the trachea; note the effect of increasing the Move Percent (figure 2).

9.	 The View Parameters window (figure 3) also allows you to specify a location by typing in 
coordinates.  Set the following coordinates:
•	 Eye		  X: 128	 Y: 150	 Z: 181
•	 Look At 	 X: 125	 Y: 142	 Z: 120
•	 Up		  X: 0		  Y: 1		  Z: 0

10.	 Click Render in the View Parameters window to display the location of the coordinates (figure 4).

Figure 1

Figure 2

Figure 3

Figure 4

Basic Controls

Advanced Controls

Exercise 21 : Virtual Endoscopy Interactive Generation of Endoscopic Views
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11.	 Reset Move Percent to 20 in the View Parameters window and click 
Done to dismiss the window.

12.	 Many times when an obvious entry location is not available, the 
‘Orthogonal Eye’ and ‘Look At’ views are very useful.  To enable these 
views, press the Eye and Look At PowerBar buttons or choose View 
> Eye and View > Look At.  When enabled, three interactive panes 
become available (figure 5) on either side of the module window, 
displaying the transverse, coronal, and sagittal sections that intersect 
with the current ‘Eye’ position [A] or ‘Look At’ point [B].  A new ‘Eye’ 
position or ‘Look At’ point can be set by clicking in any of the orthogonal 
section panes.  

13.	 Press the Manual Controls PowerBar button or choose Generate > 
Manual Controls.  The Manual Controls will appear in the main module 
window [C], allowing you to select the translation or rotation actions, the 
increment, and point(s) to manipulate.  To apply a manual action, click 
the Render button at the bottom of the main module window.  

14.	 Use the interactive Orthogonal Eye/Look At panes and the Manual Control buttons to 
navigate down into the trachea until you reach the bifurcation of the airway.

15.	 Press the Show Object PowerBar button or choose Generate > Show Object.  
The Show Object window allows the ‘Eye’ position and ‘Look At’ direction to be 
manipulated on an exterior rendering.  The rendering shows a circle indicating the 
‘Eye’ position and an arrow for the ‘Look At’ direction (figure 6).  

16.	 Close all Virtual Endoscopy windows before proceeding to the next exercise.

  tip	 The ‘Eye’ position advances toward the selected point based 
on settings in the View Parameters window (Generate > View 
Parameters).

note	 Since the visualization is created by thresholding, you 
must be “inside” the object in order for it to be rendered.

Figure 5

Figure 6

Exercise 21 : Virtual Endoscopy Interactive Generation of Endoscopic Views
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The Virtual Endoscopy module provides an interactive interface for endoscopic visualization.  Often the desired result of such an endoscopic 
exploration is a detailed endoscopic movie sequence along a specified ‘fly-through’ path.  This exercise will demonstrate how to achieve this by 
defining a path using key frames then generating all endoscopic renderings along this path. 

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual Endoscopy). 

3.	 Before beginning to record the movie, move closer to the trachea. Position the cursor 
near the center of the trachea and click three times to cause incremental movement 
towards the target.  

4.	 Press the Add Key Frame PowerBar button or choose Generate > Sequence > Add 
Key Frame to specify the first key frame (this is where the movie will begin).  

5.	 Move closer to the trachea by clicking three more times within the tracheal lumen 
(figure 1). After the movement towards the trachea has stopped, press the Add Key 
Frame button to add another key frame.

6.	 Choose Generate > Sequence > Auto Add Key Frame, this option causes any new 
viewpoint to automatically be added as a key frame.  

7.	 Continue to click within the tracheal lumen and navigate down to the bifurcation of the 
airway (approximately 9 clicks) (figure 2).

8.	 When you reach the bifurcation of the airway, click in the left bronchus to reorient the 
viewpoint down that specific branch.  Click several more times to traverse down the 
left bronchus.  

9.	 When you have moved down the left bronchus (figure 3), choose Generate > 
Sequence > Auto Add Key Frame to turn off the Auto Add Key Frame option. 

10.	 To save the sequence, choose Generate > Sequence > Save Sequence.

11.	 To generate a movie of the sequence, choose Generate > Sequence > Generate 
Sequence.  The full sequence (defined by the key frames) will now be generated by 
the module; all endoscopic renderings will be generated along the defined path.  

12.	 The fly-through movie will be available in the Analyze workspace and can be viewed 
with the Movie module (Display > Movie).  

note	 Rendering the endoscopic 
movie may take a few 
minutes depending upon 
your system and the size of 
the movie. 

Figure 1

Figure 2

Figure 3

Exercise 22 : Virtual Endoscopy Endoscopic Movie Generation
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1.	 After viewing your movie try recreating the movie adding these steps into the 
main exercise after Step 7.

2.	 When you reach the bifurcation of the airway, click in the right bronchus.  Click 
two more times to move further into the bronchus (figure 1).  

3.	 Press the Back PowerBar button three times, and then proceed down the left 
bronchus. 

4.	 At the end of the left bronchus press the Invert Positions
PowerBar button, then move back up through the left bronchus towards the 
trachea.  

5.	 When you reach the trachea choose Generate > Sequence > Auto 
Add Key Frame to turn off the Auto Add Key Frame option.  

6.	 Choose Generate > Sequence > Generate Sequence to generate the 
movie (figure 2).  

7.	 Close the Virtual Endoscopy module before proceeding to the next 
Additional Task.

Figure 1

Figure 2

1. Advanced Maneuvers

Exercise 22 : Virtual Endoscopy Endoscopic Movie Generation
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1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Virtual Endoscopy module (Display > Virtual Endoscopy).

3.	 Position the cursor over the center of the trachea and click to navigate into 
the trachea. Clicking 12 times should position you midway into the trachea 
(figure 1).

4.	 Press the Eye and Look At PowerBar buttons to enable the Eye and Look 
At views. Then press the Show Object PowerBar button to open the Show 
Object window.

5.	 In the Show Object window, click on and drag the green arrow (the Look At 
point) to the end of the airway (figure 2).

6.	 Use the Look At panels to correct the Look At position, make sure that the 
Look At position is on the airway (figure 3).

2. Generating a Centerline

The Virtual Endoscopy module provides that ability to generate the centerline of an 
endoscopic structure using the current Eye and Look At points. Key frames are automatically 
generated between the two points and displayed in the Sequence Edit window once the 
centerline has been created, allowing an endoscopic sequence to be generated along the 
centerline, thus reducing the time taken to create fly-through movies.  This task will show 
you how to create a centerline and generate the resulting endoscopic movie.

Exercise 22 : Virtual Endoscopy Endoscopic Movie Generation
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Figure 2

Figure 1
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2. Generating a Centerline

7.	 Next select Generate > Generate Centerline. The module will calculate 
the centerline between the current Eye and Look At points. Once 
calculated, the Sequence Edit tool will open displaying the automatically 
generated key frames, the centerline will be displayed in the Show Object 
window (figure 4).

8.	 To generate the endoscopic movie, select Generate > Sequence > 
Generate Sequence. The endoscopic movie based on the centerline will 
be generated and saved to the Analyze workspace.

9.	 Close all windows associated with the Virtual Endoscopy module before 
proceeding to the next Additional Task.

Figure 4

note	 If you do not have the Look At point centered exactly in the airway, you 
will receive an error when generating the centerline. If this happens, 
reposition your Look At point and try again.

Exercise 22 : Virtual Endoscopy Endoscopic Movie Generation
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1.	 Select the endoscopic fly-through movie from the Analyze workspace and open 
the Multiplanar Sections module Display > Multiplanar Sections.

2.	 Open the Intensities window View > Intensities.

3.	 In the Intensities window set Type to Colormap. Here you can generate your 
own custom color map or load an existing color map (figure 1). Load the hot_
body.lkup from the C:\BIR\images\TutorialData\Colormaps directory.

4.	 Once loaded, set Range to Data Type and then increase the Max value to 255.

5.	 To review the movie, select the Display Sections button from the PowerBar 
(figure 2).

6.	 To save the color intensified movie, select File > Output Intensified. The color 
map will be applied to a copy of the movie and saved to the Analyze workspace.

7.	 Close all windows associated with the Virtual Endoscopy module before 
proceeding to the next exercise.

Movies generated in the Virtual Endoscopy module can be given a quick update by apply a 
color map using the Multiplanar Sections module.

Exercise 22 : Virtual Endoscopy Endoscopic Movie Generation
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Figure 2
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3. Adding Color to Endoscopic Movies
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This exercise will demonstrate how to use the Image Calculator module for rudimentary image processing and manipulation.

1.	 Load both the MRI_3D_Head.avw and MRI_3D_Brain_Bin.avw data sets from the 
$:\BIR\images\TutorialData directory.

2.	 With the MRI_3D_Head data set selected in the Analyze workspace, open the Image 
Calculator module (Process > Image Calculator).

3.	 In the Image Calculator module, the MRI_3D_Head data set icon should appear in 
the white space above the calculator (figure 1).

4.	 Click the Multiply button [A] on the calculator.  

5.	 Drag-and-drop the MRI_3D_Brain_Bin data set from the Analyze workspace into the 
Image Calculator module (white space).

6.	 This first manipulation demonstrates how to multiply a grayscale data set with a binary 
data set.  The binary brain will act as a mask, all voxels in the grayscale data set 
that fall within the binary mask will be kept, while the voxels that fall outside will be 
removed.

7.	 Click the Equals button [B] on the calculator.  A dialog box will be returned stating that 
the action modifies the loaded volume, click Change a Copy of the Loaded Volume.  

8.	 The masked grayscale data will appear in the Image Calculator module; a copy will be 
automatically be saved to the Analyze workspace.

9.	 Click the Multiply button again.

10.	 Click the Matrix button [C] on the calculator.  

11.	 The Matrix Tool will open (figure 2); set to Rotate around the Z-axis 45 degrees and 
click Apply.  Click Done to close the Matrix Tool.  

12.	 Click the Equals button on the calculator.  A Transformation window will be returned; 
use the default settings and click Transform.

13.	 The transformed data will appear in the Image Calculator module and the copy in the 
Analyze workspace will be updated.

note	 In order to be able to drag-
and-drop data sets from 
the Analyze workspace 
into the module, make sure 
that the Analyze window 
is not maximized to full 
window display.

Figure 1

Figure 2

Exercise 23 : Image Calculator Image Manipulation
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14.	 Right-click on the calculator and choose Buttons; the Button Tool will 
open (figure 3).

15.	 The Button Tool includes a ‘Palette’ and ‘Key Pad’ (figure 3). To add a 
button to the main calculator, drag-and-drop it from the ‘Palette’ to the 
‘Key Pad’ area of the Button Tool. 

16.	 Click the Flip button [D] that now appears on the calculator (figure 4).  

17.	 In the Function Options window returned, check the Flip X option and 
click Apply (figure 5).

18.	 View the results by clicking the Volume Tool button [E] on the calculator.    

19.	 A copy of the data set (as specified earlier) with the manipulations 
performed has automatically been saved to the Analyze workspace.

20.	 Close the Image Calculator module before proceeding to the next 
exercise.

Figure 5

Figure 4

Figure 3

Exercise 23 : Image Calculator Image Manipulation
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The Image Calculator module performs mathematical operations on volumes, matrices and constant numerical values. The module also contains 
a number of processing functions including: subregioning (crop), flipping, resizing, shifting etc. This exercise will demonstrate how to use some of 
these additional processing tools to manipulate your data.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Calculator module (Process > Image Calculator).

3.	 In the Image Calculator module, right click on the white space and select Buttons 
from the menu options (figure 1).

4.	 In the Button Tool, select the Region Pad button [A] from the palette on the left, and 
drag and drop it onto the Key Pad [B] on the right.

5.	 After the Region Pad button has been moved to the Key Pad, hit Apply. The main 
Image Calculator key pad will be updated with the additional button option. Close the 
Button Tool.

6.	 Now drag and drop your data set from the Analyze workspace onto the Image 
Calculator process canvas, (the white space. This will load the data set into the 
module and the volume will appear on the canvas.

7.	 Hit the Region Pad button [C], the Region Pad buttons Function Option window will 
be returned (figure 4).

8.	 In this window you can subregion the data by entering Low and High values for the X, 
Y and Z options.

X Low - Specifies the first column of pixels from each slice to be loaded.
X High - Specifies the column end point
Y Low - Specifies the first row of pixels from each image to be loaded
Y High - Specifies the row end point
Z Low - Specifies the first slice from the selected volume to be loaded
Z High - Specifies the slice endpoint

Figure 1

Figure 2

Figure 3 Figure 4

Exercise 24 : Image Calculator SubRegion Data
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Example 1: Subregioning 50 slices in the X.

i.	 Set the X Low value to 25

ii.	 Set the X High value to 151

Example 2: Subregioning 50 slices in the Y.

i.	 Set the Y Low value to 25

ii.	 Set the Y High value to 211

Example 3: Subregioning 50 slices in the Z

i.	 Set the Z Low value to 25

ii.	 Set the Z High value to 162

9.	 Click on the Interactive button in the Subregion window.

Figure 5

Figure 6

Figure 7

Exercise 24 : Image Calculator - SubRegion Data
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10.	 Now use the interactive tool to subregion. Use the tool to trace a bounding box around 
the area you wish to subregion.
•	 To define the box, simply click and drag the box on the image display [A].
•	 You can review and adjust the box in all three orthogonal orientations, by using the  

T, C, or S cube icons to change orientations.
•	 You can review your subregion on all slices prior to applying the subregion, use the 

slice slider bar to navigate through the volume [B].

11.	 A subregion defined in the Interactive tool automatically updates in the X,Y and Z 
high/low values in the Region Pad Function Option window. To apply a subregion to a 
data set, hit Apply in the Region Pad Function Option window.

12.	 When you Apply a subregion you will be asked if you would like to apply the changes 
to the Loaded or if you would like to Change a Copy of the Loaded Volume. Select 
Change a Copy of the Loaded Volume. The changes made to the copy of the data 
set will automatically be saved to the Analyze workspace.

13.	 Close all windows associated with Image Calculator before proceeding to the next 
exercise.

Figure 8

Figure 9

Exercise 24 : Image Calculator - SubRegion Data
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The Image Algebra module provides an algebraic formula parser, allowing both simple and complex algebraic operations (containing up to 1000 
variables and 1000 constants) to be performed on image data.  This exercise will demonstrate the use of common algebraic processing and other 
manipulations with the Image Algebra module.

1.	 Load the Cubic_CT_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Deselect the Cubic_CT_Head data set in the Analyze workspace, and then open the 
Image Algebra module (Process > Image Algebra).	

3.	 You may remember from previous exercises (Volume Render 12 and 13), that the 
Cubic_CT_Head data set can be thresholded to 145 to show bone.

4.	 [A] Enter the formula: Output = (a > 145) * a.  Press <Enter> (figure 1)

5.	 [B] Drag-and-drop the Cubic_CT_Head data set from the Analyze workspace into the 
Image Algebra module under variable ‘a’. 

6.	 Click the Output button [C]; in the Parameters window returned, set Name to Bone.  
Click Done to dismiss the window.

7.	 Click Go [D] in the main Image Algebra window to begin processing.  

8.	 Once processing is complete, right-click on the Output icon and select Display to 
examine the data with all voxels less than 145 removed (figure 2).  Close the Display 
tool once the data has been reviewed. 

9.	 In the Image Algebra module edit the formula: Output = (a < 145) * a.  Press <Enter>.  
All voxels greater than 145 will now be removed from the data set.

note	 The Image Algebra module 
remembers parameters from previous 
Image Algebra sessions.  If the 
module detects parameters from a 
past session, it will prompt the user to 
remember or forget these settings.

Figure 1

Figure 2

Exercise 25 : Image Algebra Formula for Image Manipulation

Thresholding Data

Manipulating Data 
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10.	 Click the ‘a’ button to view the parameters for variable ‘a’ (figure 3).  Click Done to 
dismiss the Parameters window. 

11.	 Click the Output button and change Name to NoBone.  Click Done to dismiss the 
window.

12.	 Click Go in the main Image Algebra window to begin processing.  

13.	 Once processing is complete, right-click on the Output icon and select Display to 
examine the data with bone removed. 

14.	 Now, try adding the bone back in with the new formula: Output = (b >= 1) * b + (b < 
1) * a. Press <Enter> (figure 4).  

15.	 Since we have reused the ‘a’ variable, the Image Algebra module will remember the 
data associated with it from the previous example.  However, this is the first time 
the ‘b’ variable has been specified, so drag-and-drop NoBone (from Output or the 
Analyze workspace) to the area under variable ‘b’.

16.	 Click the Output button and change Name to BoneAdded.  Click Done to dismiss the 
window.

17.	 Click Go to process the new formula (figure 4).  

18.	 Once processing is complete, right-click on the Output icon and select Display to 
examine the data with the bone added back. 

19.	 Right-click in the formula field and explore some of the example formulas provided.

20.	 Close the Image Algebra module before proceeding to the next exercise.

Figure 3

Figure 4

Exercise 25 : Image Calculator Formula for Image Manipulation
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The Histogram Operations module provides the ability to do histogram processing, such as histogram matching, flattening, and equalization 
(normalization).  The goal of this exercise is to demonstrate how to normalize the histograms of SPECT images taken under different conditions.

1.	 Load both the SISCOM_Ictal_SPECT.avw and SISCOM_Interictal_SPECT.avw 
data sets from the $:\BIR\images\TutorialData directory.

2.	 With only the SISCOM_Ictal_SPECT data set selected in the Analyze workspace, 
open the Histogram Operations module (Process > Histogram Ops).

3.	 Open the Function window (Generate > Function).

4.	 In the Function window select Histogram Normalize and set the following 
parameters (figure 1):
•	 Use Histogram: Median
•	 Target Value: 150
•	 Image Display: Original and Filtered
•	 Histogram Display: On

5.	 Click Filter.  An Input and Output Histogram will automatically be returned.  The 
filtered result will be displayed in the main Histogram Operations window.  

6.	 In the Function window change Action to Memory and click Filter again.  A dialog 
box will be returned stating that the action modifies the loaded volume, click 
Change a Copy of the Loaded Volume.

7.	 Drag-and-drop the SISCOM_Interictal_SPECT data set from the Analyze 
workspace into the main Histogram Operations window.  

8.	 Press the Filter PowerBar button.  In the dialog box returned, click Change a Copy 
of the Loaded Volume. 

9.	 The two new volumes you have created have been normalized to the same value, 
so equivalent numbers in the images now indicate levels of metabolic activity 
(figure 2).  Additionally, both normalized volumes have automatically been saved to 
the Analyze workspace.

10.	 Close the Histogram Operations module before proceeding to the next exercise.

Figure 1

Figure 2

Exercise 26 : Histogram Operations Histogram Normalization
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The Spatial Filters module enables the application of two-dimensional and three-dimensional filters to image data.  This exercise will demonstrate 
how to apply a filter in the Spatial Filters module to your data.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Spatial Filters module (Process > Spatial Filters).

3.	 Open the Preview Options window (Generate > Preview Options).

4.	 Select the Loaded and Preview Volumes option (figure 1).  
This will preview the original data set and a copy of the data set with any filter applied, 
side-by-side.

5.	 Open the Filters window (Generate > Filters).  

6.	 In the Filters window, select the Low Pass filter by clicking the radio button next to the 
option (figure 2).

7.	 Now, click Preview [A].  The original data set and the filtered data set will be 
displayed side-by-side in the main Spatial Filters window (figure 3), the filtered data 
set appears on the right. 

8.	 Preview several other filters, noting the effect of each.

9.	 To apply a filter to the data set, click Filter [B] in the Filters window.  A dialog box will 
be returned stating that the action modifies the loaded volume, click Change a Copy 
of the Loaded Volume.

10.	 A filtered copy of your volume will be saved to the Analyze workspace.

11.	 Close the Spatial Filters module before proceeding to the next exercise.

Figure 1

Figure 2

Figure 3

Exercise 27 : Spatial Filters
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Segmentation
Analyze 10.0
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The Image Edit module provides a number of manual segmentation tools.  This exercise will demonstrate how to segment grayscale data using the 
auto trace tool.  For a full overview of all the segmentation tools in the module, please review the Image Edit tutorial available from the Help menu in 
the Analyze window.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Open the Slice window (Generate > Slice), and use the slider bar to move to 
Slice 122.  

4.	 In the main Image Edit window, select the Auto Trace tool [A].  Position the cursor 
near the center of the brain and click to set a seed point.  The Image Edit window will 
automatically update to display Auto Trace parameters (figure 1).

5.	 Use the double-ended slider bar at the bottom of the window [B] to adjust the 
threshold range until a reasonable trace of the brain is obtained.  A threshold 
minimum of 34 and maximum of 129 works well for this data set.

6.	 Select the Delayed Flood Fill tool and place a fill point outside the auto-traced region 
(click on the background). 

7.	 Select the Auto Trace tool again and click Apply & Advance [C].  

8.	 A dialog box will be returned stating that 
the action modifies the loaded volume, 
click Change a Copy of the Loaded 
Volume.  The area outside the trace will 
be highlighted in red, and then the next slice will appear in the image display (the slice 
number can be seen in the lower left corner of the image display [D]).

9.	 Review the edited slice by opening the Edit Review Tool (Tools > Edit Review) 
(figure 2). 

10.	 In the main Image Edit window, you will notice that when the module advanced to 
slice 123 (step 8) the seed point and auto trace parameters set in step 5 were copied 
forward.  The trace should have automatically adjusted to the brain on this slice.  If 
not, the seed point may have been copied forward to an area outside the brain or to 
a voxel with a different grayscale value.  Use the Move button and adjust the seed 
point. 

note	 An edited version of the data set will 
be automatically saved to the Analyze 
workspace.

Figure 1

Figure 2

Exercise 28 : Image Edit Manual Segmentation of Grayscale Data



Analyze 10.0 Essential Training Guide 83

11.	 If the trace needs no further adjustment and the Delayed Flood Fill point is still 
positioned outside the trace, click Apply & Advance and edit 19 more slices, finishing 
on slice 142. 

12.	 In the Edit Review tool, change the orientation to Coronal and then Sagittal, note the 
slice edits in these orientations (figure 3).

13.	 To create a rendering of the edited data complete the Additional Task.  

1.	 Continue to segment the data set until approximately slice 181 to remove the 
entire top of the head.

2.	 Close the Image Edit module.

3.	 Select the MRI_3D_Head0 data set in the Analyze workspace and then open 
the Volume Render module (Display > Volume Render). 

4.	 Open the Thresholds window (Display > Thresholds).

5.	 Set the Minimum threshold level to 50, then click Render.  The rendering 
will be displayed in the main Volume Render window (figure 4).

6.	 Close the Volume Render module before proceeding to the next exercise.

Figure 3

Figure 4
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1. Rendering Segmented Data

Exercise 28 : Image Edit Manual Segmentation of Grayscale Data
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As discussed in Exercise 13: Volume Render Advanced Controls, object maps are special image files that are used in Analyze to partition and 
identify structures as belonging to a particular segmented object.  This exercise will demonstrate how to create an object map containing manually 
segmented objects. 

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Image Edit module (Segment > Image Edit).

3.	 Choose File > Create Object Map.  The Objects window (View > Objects) will 
automatically be returned (figure 1).    

4.	 Click Add Object [A] to create a new empty object (Object_2). 

5.	 Change Name from Object_2 to Brain [B].  Click Done to dismiss the Objects 
window.

6.	 Open the Slice window (Generate > Slice), and use the slider bar to move to Slice 
122.  

7.	 At the bottom of the main Image Edit window, set Change to Object Map and choose 
Brain from the Defined Object drop-down menu [C]. 

8.	 Select the Auto Trace tool, the Image Edit window will automatically update to 
display Auto Trace parameters (figure 2).  

9.	 Position the cursor near the center of the brain and click to set a seed point.  Use the 
double-ended slider bar [D] at the bottom of the window to adjust the threshold range 
until a reasonable trace of the brain is obtained.  A threshold minimum of 34 and 
maximum of 129 works well for this data set.

10.	 Select the Delayed Flood Fill tool and place a fill point inside the auto-traced region 
(click inside the region).  

11.	 Select the Auto Trace tool again.  

12.	 Click Apply & Advance.  The next slice will appear in the image display (the slice 
number is displayed in the lower left corner [E]).

note	 If you did not set the ‘Change’ option to Object Map (step 7) the 
defined region will appear black in the Edit Review tool.

Figure 1

Figure 2

Exercise 29 : Image Edit Manual Segmentation and Object Map Creation
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13.	 View the edited object map by opening the Edit Review Tool (Tools > Edit Review).   

14.	 Select the Previous option in the Edit Review tool.  The change can also be viewed by 
selecting the Sagittal option.

15.	 With the Auto Trace tool selected, continue to segment slices by clicking Apply & 
Advance in the main Image Edit window.  Segment the brain on 20 slices (to slice 142).

   

16.	 To save the created object map for use in other Analyze modules, choose File > Save 
Object Map.  Save the object map as xxx_mybrain.obj (where ‘xxx’ are your initials).

tip	 If the auto trace does not apply to a slice, or leaks to unwanted structures, try the 
following: 1) adjust the threshold range, 2) draw a limit after selecting the ‘Add Limit’ 
button, or 3) turn on the ‘Auto Limit’ option and adjust the ‘Gap Size’.  Additionally, 
the auto trace can be adjusted on a slice by moving the seed point with the ‘Move’ 
button selected.

1.	 In the Analyze workspace, select the MRI_3D_Head data set and open the 
Volume Render module (Display > Volume Render).  

2.	 Choose File > Load Object Map and load the xxx_mybrain.obj object map 
(saved earlier in step 16).

3.	 Open the Objects window (View > Objects).  Set Control by to Attribute 
and set the Display attribute to Off for the Original object.

4.	 Click Render.  You should see a rendering of the object you created in the 
Image Edit module.  

5.	 Use the Rotation window (Generate > Rotation) to generate different views 
of the object (figure 2).

Figure 1

Figure 3
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1. Viewing the Object Map in Volume Render

Exercise 29 : Image Edit Manual Segmentation and Object Map Creation
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The Morphology module applies 1-D, 2-D, or 3-D mathematical morphological transformations and object topology operations to a data set. This 
exercise will demonstrate the morphological segmentation tools available in the module by showing how to segment the brain from an MRI data set.

Figure 1

Figure 2

Figure 3

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Morphology module (Segment > Morphology).

3.	 From the Generate menu, open the Slice tool. Move the slice slider to slice 130.

4.	 Open the Step Editor window (Generate > Step Editor) (figure 1).

5.	 Click the Threshold button [A]. In the Step 1: Threshold window returned, set the 
Threshold Min to 65. Click Threshold Volume. In the window returned, select Change 
a Copy of the Loaded Volume.

6.	 Select Generate > Display Section(s) > Current to review that data.

7.	 Select File > Save Volume. Save the volume as MRI_3D_Head_bin.

8.	 Click the Erode button [B]. In the Step 2: Erode window, change the Element Depth to 
3 and change the value Iterations to 2. Click Erode Volume (figure 2).

9.	 In the Step Editor window, click Transform Volume. A dialogue box will be returned, 
select Yes.

10.	 Click Connect [C]. Change Max. No. of Components to 1. Click Connect Volume. 

11.	 In the Step Editor window, click Conditional Dilate [D]. In the Conditional window, 
change Element Depth to 3 and change Iteration to 1. Next load the conditional 
volume by clicking the Volume button. Use the window returned to select the MRI_3D_
Head_bin.avw data set saved in step 7. Press the Cond. Dilate Volume button.

12.	 To view your segmentation, select Generate > Display Section(s) > Current (figure 3).

13.	 The binary segmentation is available in the Analyze workspace. To obtain a suitable 
volume for further analysis multiply the binary volume by the input grayscale volume 
using the Image Calculator or Image Algebra modules.

14.	 When you are finished reviewing, close all windows related to the Morphology module 
before proceeding to the next module.

note	 Notice the left side of the Step Editor window; 
as operations are selected from below the 
Morph Operations, the sequence of steps is 
maintained on the left.

Exercise 30 : Morphology Morphological-Based Segmentation
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The goal of this exercise is to demonstrate how to automatically strip the skull from in a T1- or T2-weighted MRI scan.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Watershed module (Segment > Watershed).

3.	 The Watershed module default parameters usually allow for a successful 
segmentation of the brain.  Check the Always Display option and view the red pixels 
that define the ‘Pre-Fill’ level on different slices and orientations.  Do not change the 
Pre-Fill Value (49).

4.	 Click Watershed Segment Volume to initialize the automatic segmentation.

5.	 After the automatic segmentation process has completed, the Results tab is 
automatically selected (figure 1).  Each segmented object will appear as a different 
random color in the image display.

6.	 With the Render Selected Object option selected, click on the object that represents 
the brain in the image display.  

7.	 The Render Tool will automatically be returned (figure 2), allowing you to review the 
segmented objects from difference orthogonal orientations.  You can also click and 
drag the rendering to a new view in the Render Tool image display.

8.	 Select the Create Masked Volume from Selected Object option from the Results 
tab.  Then, click again on the object that represents the brain.  The Compare window 
that appears allows you to review the original and segmented volume side-by-side, 
slice-by-slice in different orthogonal views.

9.	 The File menu provides options to save the segmented object, the masked volume, 
and an object map of the segmented object.

10.	 Choose File > Save Masked Volume.  In the window returned, set Destination to 
Analyze Workspace and then click Save Volume.  The object clicked on in step 8 
after selecting ‘Create Masked Volume from Selected Object’ will be saved to the 
Analyze workspace.  Click Done to dismiss the Save Masked Volume window.

11.	 Close all windows before proceeding to the next exercise.

Figure 1

Figure 2

Exercise 31 : Watershed Automated Segmentation
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The goal of this exercise is to demonstrate the use of the Scattergram tool in the Multispectral Classification module to illustrate the various 
supervised classifiers in the multispectral measurement space.

1.	 Load the MRI_multi.avw data set from the $:\BIR\images\
TutorialData\MultiSpectralTutorial directory.  This file contains 
a spatially co-registered MRI T1 and T2 volume of the same 
patient.  

2.	 Open the Multispectral Classification module (Segment > 
Multispectral Classification).

3.	 Open the Scattergram window (Samples > Scattergrams). 

4.	 In the Scattergram window (figure 1), move the Slice slider 
bar [A] to slice 14.  The T1 and T2 sections are displayed side-by-side along with 
the scattergram of the pixels.  To increase the image display size, change Single to 
Double in the drop-down menu [B] next to the ‘Slice’ slider bar.

5.	 Select the Closed Trace tool and define a small region of white matter (central brain 
tissue) as class 1 by drawing on the image display.   The paired values found in this 
region are colored red in the scattergram display and on the image displayed in the 
main Multispectral Classification window (figure 2). 

6.	 Select the Curved Line tool and define a small region of grey matter (peripheral brain 
tissue) as class 2.  Make sure to choose ‘class 2’ from the Classes drop-down menu 
[C] before starting the trace.  The paired values will show as green in the scattergram 
and in the image display.  

note	 If you use the Load As module to load 
the data set into Analyze, select ‘Single 
Multivolume’ when prompted.

  tip	 To move a defined region hold <Shift> then click and 
drag the region to the desired location.

Figure 1

Figure 2

Exercise 32 : Multispectral Classification
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7.	 Select the Closed Trace tool and define a small region of cerebrospinal fluid (in the 
central ventricles) as class 3.  

8.	 Click Classify Images.  The Gaussian Scattergram Classifier window will 
automatically be returned (figure 3), click Classify.  Click Done to dismiss the window.

9.	 Choose Scattergram & Classified from the drop-down menu below the far right pane 
of the Scattergram window to view the Gaussian class boundaries derived from the 
samples (figure 4).

10.	 By selecting classifiers other than ‘Gaussian Cluster’ in the Scattergram window 
before clicking Classify Images, other supervised classifiers can be demonstrated on 
the same samples.

11.	 Close the Multispectral Classification module before proceeding to the next exercise.
Figure 3

Figure 4

Exercise 32 : Multispectral Classification
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The Object Extractor module applies thresholding, morphology erosion and dilation, and region growing steps in an attempt to automatically 
segment an object within a volume.  This exercise will demonstrate how to use this module.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin the 
segmentation process.  

4.	 To define an auto trace on any slice of the volume, first specify a starting slice using the 
‘Slice’ slider bar.  Slice 141 is an excellent starting point for this data set.  Note that the 
orientation can be changed using the Extract Options directly below the slider bar.  

5.	 In order to define a threshold range for the auto trace, a seed point must be set.  Position 
the cursor near the center of the brain and click to set a seed point.  

6.	 The Define Region window will automatically update (figure 1) to display auto trace 
parameters.  Use the double-ended slider bar [A] now 
available to set the Threshold Minimum to 49 and the 
Maximum to 140.

7.	 Click Extract Object to start the object extraction 
process.  The grayscale copy of the extracted object 
will automatically be saved to the Analyze workspace.  

8.	 Once the process is complete, a rendering of the extracted object will be displayed in 
the main Object Extractor window.  The Render Tool will also automatically be returned, 
allowing you to view the object from different orientations (figure 2).

9.	 The resulting extraction can be further examined in the Compare window (Generate 
> Compare).  The Compare window will allow the user to compare the original and 
segmented volume slice-by-slice.  

10.	 If the extraction is not satisfactory, the data may be re-segmented by clearing the regions 
in the Define Region window (Generate > Define Region) and selecting a new seed 
point and threshold range.  

11.	 Close the Object Extractor module before proceeding to the Additional Tasks.

note	 Click the Clear Regs button [B] at 
any time to remove all traces and 
limit ranges. A new starting slice 
may also be defined if required by 
clicking the Target Slice button [C]. Figure 1

Figure 2

Exercise 33 : Object Extractor Automated Brain Segmentation
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As introduced in earlier exercises, an object map is a special image file used by Analyze to 
partition and identify structures as belonging to a particular segmented object.  Voxels in the 
image volume correspond directly, on a one-to-one basis, with a voxel in the object map, 
whose value assigns the voxel to a particular segmented object.  Since object map files can 
also be loaded into other Analyze modules, the same objects within an image volume can be 
referenced for a variety of purposes (see Exercise 47: Region of Interest Measuring Objects in 
Object Maps).  This exercise will demonstrate how to create an object map in Object Extractor.

1.	 Select the MRI_3D_Head.avw data set loaded in the Analyze workspace and 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point.  Set the Threshold Minimum to 49 
and the Maximum to 140.

4.	 Click Extract Options and set the Result to Object (figure 1).  A dialog box 
will be returned asking if you would like to create an object map, click Yes 
(figure 2).  Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the object 
extraction process.  

6.	 Once the extraction process is complete the object will be displayed overlaid 
on the original image data in the main Object Extractor window (figure 3).  
The Render Tool will also automatically be returned, allowing you to view the 
object from different orientations.

7.	 The object map will not be automatically saved, if you wish to save the object 
map choose File > Save Object Map.

8.	 Close the Object Extractor module.  To learn how to create a binary object 
with the Object Extractor proceed to the next Additional Task.

1. Extract Options - Creating an Object Map

Figure 1

Figure 2

Figure 3
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Occasionally it is necessary to save the segmented object as a binary object, as opposed to a 
grayscale object like in the first part of this exercise.  This additional task will demonstrate how 
to achieve this.  

1.	 Select the MRI_3D_Head.avw data set in the Analyze workspace and then 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point.  Set the Threshold Minimum to 49 
and the Maximum to 140.

4.	 Click Extract Options and set the Result to Binary (figure 1).  Click Done to 
dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the object 
extraction process.  

6.	 Once the process is complete, a rendering of the extracted object will 
be displayed in the main Object Extractor window.  The Render Tool will 
automatically be returned again, allowing you to view the object from different 
orientations.  The segmented binary brain will be automatically saved to the 
Analyze workspace and can now be used with any other Analyze module.

7.	 Close the Object Extractor module before proceeding to the next Additional 
Task.

2. Extract Options - Creating a Binary Object

Figure 1
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The Object Extractor module now provides the option to automatically remove the brain 
stem from your segmented brain. This task will demonstrate how to segment and remove 
the brain stem.

1.	 Select the MRI_3D_Head.avw data set in the Analyze workspace and then 
open the Object Extractor module (Segment > Object Extractor).

2.	 Open the Define Region window (Generate > Define Region) and set the 
Target Slice to 141.

3.	 Click inside the brain to set a seed point. Set the Threshold 
Minimum to 49 and the Maximum to 140.

4.	 Click Extract Options and set the Remove Stem option to On 
(figure 1). Click Done to dismiss the Extract Options window.

5.	 In the Define Region window, click Extract Object to start the 
object extraction process.

6.	 Once the process is complete, a rendering of the extracted brain 
with the brain stem removed will be displayed in the main Object Extractor 
window. The Render Tool will also automatically be returned (figure 2), 
allowing you to view the object from different orientations. The segmented 
grayscale brain will be automatically saved to the Analyze workspace and can 
now be used with any other Analyze module.

7.	 Close the Object Extractor module before proceeding to the next exercise.
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3. Extract Options - Automatic Brain Stem Removal

Figure 1

Figure 2

Exercise 33 : Object Extractor Automated Brain Segmentation
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The Object Extractor module supports the creation of multi-object object maps. This exercise will demonstrate how to achieve this. 

1.	 Load the CT_Lungs.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Extractor module (Segment > Object Extractor).

3.	 Open the Define Region window (Generate > Define Region) to begin the 
segmentation process.  

4.	 To define an auto trace on any slice of the volume, first specify a starting slice using 
the ‘Slice’ slider bar.  Slice 104 is the default slice, and it is an good starting point for 
this data set. 

5.	 Position the cursor near the center of the left lung and click to set a seed point.  

6.	 The Define Region window will automatically update (figure 1) to display auto trace 
parameters. Use the double-ended slider bar [A] now available to set the Threshold 
Minimum to 18 and the Maximum to 99.

7.	 Click the Extract Options button, and set the Result to Object (figure 2), select Yes 
in the window returned.

8.	 In the Define Regions window, click Extract Object to start the object extraction 
process.  The left lung will be extracted and saved as the object called ‘Extracted’. 
The object will appear red.

9.	 Open the Define Regions window again, when opened click the Clear Regions button 
[B]. Next, click in the right lung to set a seed point, set the Threshold Minimum to 18 
and the Maximum to 104. 

10.	 Click Extract Object again. The right lung will be extracted and saved as the object 
called Extracted (2), the object will appear green. In the main Object Extractor 
module you will see both lungs (figure 3). 

Figure 1

Figure 2

Figure 3

Exercise 34 : Object Extractor Extracting Multiple Objects
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11.	 The render window will now display both lungs in 3D (figure 4). 

12.	 To change the name and color of each object, go to the Objects window (View > 
Objects). Set Control By to Attribute, and from the drop down menu select the 
Name and Color attribute options (figure 5).

13.	 To save the object map for use in other modules, select File > Save Object Map.

14.	 Close all windows related to the Object Extractor module before proceeding to the 
next exercise.

Figure 4

Figure 5

Exercise 34 : Object Extractor - Extracting Multiple Objects
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Polygonal surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as sets of vertices and polygons.  This conversion must optimally extract a representative surface, with as much detail as possible, but do 
so with as few vertices and polygons as possible.  This exercise will use the Adapt/Deform algorithm to perform such an optimal surface extraction.  
Often this surface extraction is a precursor to using the surface with other applications, such as CAD/CAM modeling, rapid prototyping (model 
building), and finite element analysis. 

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).

5.	 Click Objects [A] at the top of the Extraction Parameters window (figure 1).  In the 
window returned, leave the Brain set to On and set all other objects to Off.  Click 
Done to dismiss the window.

6.	 Create a polygonal surface of the ‘Brain’ object using the Adapt/Deform algorithm with 
the default parameters.  With the AdaptDeform tab selected click Extract [B].

7.	 A dialog box will be returned stating the number of polygons generated.  Note the 
number of polygons (approximately 37,258), then click Done.

8.	 To create a rendering of the surface model, choose Generate > Render.  A surface 
map will automatically be created for the ‘Brain’ surface, and the Surfaces window 
returned.  The rendering will be displayed in the main Surface Extractor window 
(figure 2).

9.	 In the Extraction Parameters window change the Cube Edge Size [C] to 5 and 
rebuild the surface by clicking Extract.  Note, the number of polygons generated 
(approximately 12,261), then click Done.  

10.	 Choose Generate > Render to view the extracted surface with the new parameters 
(figure 3).  Increasing the ‘Cube Edge Size’ will smooth the surface, reducing the 
number of voxels considered when generating the initial surface estimate, which 
reduces the polygon count.  

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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11.	 Click Reset [D] in the Extraction Parameters window to restore the default parameters 
(‘Cube Edge Size’ of 3).

12.	 Click Advanced [E] and change the Time Step to 0.5.  Click Done to dismiss the 
window.

13.	 Rebuild the surface by clicking Extract in the Extraction Parameters window.  Note 
the number of polygons generated (approximately 37,258), then click Done.  

14.	 Choose Generate > Render to view the extracted surface with the new parameters.  
Increasing the ‘Time Step’ causes the surface extraction to reach equilibrium faster, 
producing a smoother surface without altering the polygon count.  When the opposite 
changes are made, the surface will conform to the voxel surface better, resulting in a 
rougher, more “voxelated” surface.

15.	 Decreasing the Surface Force and increasing the Spring Constant (also ‘Advanced’ 
options) smooths the surface without altering the polygonal count by forcing the 
polygons to bridge small variations in the voxel surface (the polygon’s attraction to the 
surface is reduced and they become harder to bend). 

16.	 Press the Save Surface PowerBar button or choose File > Save Surface > To File to 
save the extracted surface to disk.  

17.	 In the Save Surface window returned (figure 4) you can select from the following 
surface description formats in the Format drop-down menu: Alias (.obj), Autocad 
(.dxf), Compressed Iges (.iges), Iges (.iges), Inventor (.iv), Patran (.out), Poly (.poly), 
3D Systems (.stl), Binary 3D Systems (.stl), Vrml (.wrl).

18.	 Close the Surface Extractor module.  To learn about extracting the surface of a binary 
data set, complete the following Additional Task.

note	 Increasing the resolution increases the processing time, this is demonstrated 
by setting the ‘Cube Edge Size’ to ‘1’.  In cases where a high resolution (Cube 
Edge Size of 1) is required, use the Marching Cubes algorithm.

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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1.	 Load the MRI_3D_Brain_Bin.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Open the Extraction Parameters window (Generate > Extraction). 

4.	 With the AdaptDeform algorithm tab selected, click Extract.

5.	 Note the number of polygons generated (approximately 37,504) and choose 
Generate > Render to view the extracted surface (figure 1).

6.	 Close the Surface Extractor module before proceeding to the next exercise.

Polygonal Formats
Alias Wavefront	 (.obj) Read and Write
Autocad 	 (.dxf) Read and Write
IGES	 (.iges) Write only
Compressed IGES 	 (.iges) Write only
Inventor 	 (.iv) Write only
Patran	 (.out) Write only
Poly	 (.poly) Read and Write
Binary 3D Systems	 (.stl) Raad and Write
VRML	 (.wrl) Write only

Contour Formats
HP 3D	 (.hpgl) Write only
IGES	 (.iges) Write only
Compressed IGES	 (.iges) Write only
Pogo 	 (.slc) Read and Write
3D Systems Stereolithography	 (.slc) Read and Write
ASCII Columns	 (.txt) Read and Write

Supported Surface File Formats
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1. Extracting the Surface of a Binary Data Set

Exercise 35 : Surface Extractor Polygonal Surface Extraction
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Contour surface extraction is the process of converting an object in the voxel-based volume to a representation of the surface of the object, 
expressed as a series of stacked contours.  This surface extraction is a precursor to other applications, such as CAD/CAM modeling, rapid 
prototyping (model building), and finite element analysis.  This exercise demonstrates how to use the Contours algorithm.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Surface Extractor module (Segment > Surface Extractor).

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map.

4.	 Open the Extraction Parameters window (Generate > Extraction).  

5.	 Click Objects [A] at the top of the Extraction Parameters window (figure 1).  In the 
window returned, switch the Ventricle to On and set everything else Off.  Click Done 
to dismiss the window.

6.	 Create a contour surface of the ‘Ventricle’ object using the Contours algorithm with the 
default parameters.  Select the Contours tab and click Extract.

7.	 A dialog box will be returned stating the number of slices for which contours were 
generated.  Note the number of slices used (60), then click Done.

8.	 To create a rendering of the extracted contour model, choose Generate > Render.  

9.	 In the Extraction Parameters window, click Advanced [B] in the ‘Contours’ tab.  Check 
the Subvolume Extraction option and click Done to dismiss the window (figure 2).  

10.	 Rebuild the contour surface by clicking Extract in the Extraction Parameters window.  
Note the number of slices used (108).  This resamples and reformats the object and 
thus changes the number of slices.

11.	 Choose Generate > Render to create a rendering of the extracted contour model 
(figure 3).  

12.	 Close the Surface Extractor module before proceeding to the next exercise.  

Figure 1

Figure 3Figure 2

Exercise 36 : Surface Extractor Contour Surface Extraction
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Registration
Analyze 10.0
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Surface matching is fast and robust, even in the presence of image noise and incomplete overlap of the image volumes. Both volumes must 
contain common objects, which must be explicitly segmented from the grayscale image data and saved as a grayscale or binary image. A surface is 
extracted from both a “base object” and a “match object” that are preprocessed from the base volume and match volume, respectively. This exercise 
will demonstrate how to achieve an optimal registration of two 3D volumes based on corresponding surfaces.

1.	 Load the Edited_MRI_Head.avw and the Edited_PET_Head.avw data sets from the 
$:\BIR\images\TutorialData directory. 

2.	 Select the Edited_MRI_Head.avw data set, then while holding down the <Ctrl> key, 
select the Edited_PET_Head.avw data set.

3.	 Open the 3-D Surface Registration module (Register > 3-D Surface).

4.	 Select File > Input/Output Ports to view the import and output ports at the bottom of 
the main 3-D Surface Registration window. Make sure that Edited_MRI_Head is the 
base volume, and Edited_PET_Head is the match volume.

5.	 Open the Blend window (Generate > Blend). Set the Blend Type to Green-Red.

6.	 Examine the combined images to determine if they need to be registered. 

7.	 Select Generate > Register to register the two volumes. 

8.	 Select File > Save Transformed and save the transformed PET to the Analyze 
workspace.

9.	 Close the 3-D Surface Registration module before proceeding to the next exercise.

Figure 1

Exercise 37 : Registration 3-D Surface Registration
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The 3-D Voxel Registration module is an implementation of the Normalized Mutual Information algorithm and allows users to spatially register two 
volume images.  The module contains several unique and powerful algorithms that will allow the precise alignment of 3-D data to be achieved, both 
quickly and efficiently.  This exercise will demonstrate how to register two images of different modalities.

1.	 Load both the MRI_Head.avw and PET_Head.avw data sets from the $:\BIR\
images\TutorialData directory.

2.	 In the main Analyze workspace, first select the MRI_Head data set.  Then, while 
holding down the <Ctrl> key, select the PET_Head data set (resulting in both 
being selected).  

3.	 Open the 3-D Voxel Registration module (Register > 3-D Voxel).

4.	 Choose File > Input/Output Ports to ensure that MRI_Head is assigned as the 
‘Base Volume’ and PET_Head is assigned as the ‘Match Volume’.

5.	 The main interface contains nine image display panes (figure 1).   

•	 First Column: Displays the ‘Base’ volume (MRI_Head)  
•	 Last Column: Displays the ‘Match’ volume (PET_Head) pre-scaled to the 

size of the base volume 
•	 Middle Column: Displays the base and match volumes fused together
•	 Rows: Display the volumes in the transverse, coronal, and sagittal orientations

6.	 By default, the volumes are displayed with cubic voxels.  To turn off the cubic 
display press the Toggle Cubic PowerBar button.  For this exercise leave cubic 
display on.  

Figure 1

Main Interface Features

Exercise 38 : Image Registration 3-D Registration using MRI and PET
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7.	 Open the Blend window (Generate > Blend).  The Blend window provides different 
settings to help visually evaluate the registration.  Experiment with the different blend 
options (figure 2) and then click Done to dismiss the window.  

8.	 The crosshair in each of the image display panes can be used to move through 
the volumes.  When the crosshair is moved in any of the panes, the other panes 
automatically update to display the same volume coordinate.  Note, the base and 
match coordinates are reported at the bottom of the window.

9.	 Right-click on any of the image display panes to view options for controlling individual 
tiles, reference lines, image sizes, annotations, and interactivity.

10.	 For this exercise, no parameters need to be changed for a successful registration, 
the default settings are appropriate.  Press the Register PowerBar button or choose 
Generate > Register.  

11.	 After registration is complete you will see that the PET volume has been scaled, 
rotated, and translated to match exactly the sagittal MRI. To evaluate the registration, 
move the crosshair in any of the panes and change the ‘Blend’ type to ‘Average’.

12.	 To view the current transformation matrix open the Matrix Tool (Tools > Matrix).  You 
may manually enter rotations, translations, and scaling to the matrix by selecting an 
option and increment (figure 3).  You may also save the current matrix as an ASCII 
floating-point file or load a previously saved matrix.

13.	 You may also use manual correction buttons in the Manual tool (Tools > Manual) to 
incrementally change the registration matrix.  The buttons move the match volume 
section in the directions indicated, and then adjust the 3-D matrix depending upon the 
orientation selected.  

Figure 2

Figure 3

Registration

Exercise 38 : Image Registration 3-D Registration using MRI and PET
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14.	 To save a copy of the transformed match volume (PET_Head), choose File > Save 
Transformed; the transformed volume can be saved to disk or to the main Analyze 
workspace (figure 4).

15.	 To save the fused volume, choose File > Save Fused; the fused volume can be 
saved to disk or to the main Analyze workspace.

16.	 Close the 3-D Voxel Registration module before proceeding to the Additional Task.
Figure 4

Saving Transformed and Fused

Exercise 38 : Image Registration 3-D Registration using MRI and PET
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1.	 Select the MRI_Head.avw data set. Then while holding down the <Ctrl> key, 
select the PET_Head.avw data set (resulting in both being selected).

2.	 Open the 3-D Voxel Registration module (Register > 3-D Voxel).

3.	 To access the Adjust Scale tool, open the Manual Registration tool from the 
Tools > Manual menu (figure 1). Check the Adjust Scale option, the Manual 
Registration tool will update with X, Y, and Z scale tools. 

4.	 Adjust the scale of the Match data up and down in each orientation by click on 
the arrow up and arrow down keys. Note the display of the Match data each 
time the scale is adjusted. 

5.	 Close all windows associated with the 3-D Voxel Registration module before 
proceeding to the next exercise.

Figure 1
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1. Manual Scale Adjustment

The Manual Registration tool in both the 3-D Voxel and Surface Registration modules now provides the ability for users to manually adjust 
the scale of the Match data prior to registration.  This task will demonstrate how to access and use the new Adjust Scale tool.

Exercise 38 : Image Registration 3-D Registration using MRI and PET
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This exercise will demonstrate how to adjust a 3-D registration starting position to achieve an optimal registration of two 3-D volume images.

1.	 Load both the Register_MRI_Base.avw and Register_MRI_Match.avw data sets 
from the $:\BIR\images\TutorialData directory.

2.	 In the Analyze workspace, first select the Register_MRI_Base data set.  Then, while 
holding down <Ctrl> select the Register_MRI_Match data set (resulting in both being 
selected).  

3.	 Open the 3-D Voxel Registration module (Register > 3-D Voxel).

4.	 Choose File > Input/Output Ports to ensure that Register_MRI_Base is assigned as 
the ‘Base Volume’ and Register_MRI_Match is assigned as the ‘Match Volume’.

5.	 Open the Blend window (Generate > Blend).  Select the Red-Green blend and then 
click Done.  The ‘Red-Green’ blend option will help evaluate the registration.  

6.	 Press the Register PowerBar button or choose Generate > Register.  

7.	 Examine the center ‘Fused’ column of the main module window (figure 1).  As you can 
see, the registration is not acceptable.

8.	 Since the registration is not acceptable, manually adjust the starting point of the 
registration.  Open the Manual tool (Tools > Manual).  

9.	 Click Reset Matrix in the Manual tool (figure 2), this will reset the match volume to the 
original starting position. 

10.	 Now, using the Manual tool options, move the match volume to a better starting 
position and press Register.

11.	 If the registration is still not acceptable, return to the Manual tool and click Reset 
Matrix again.

Figure 1

Figure 2

Exercise 39 : Image Registration Mutual Information Registration

Manual Adjustment
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12.	 Now, select the Coarse adjustment option [A] and press the down arrow button once.  

13.	 Change the orientation from coronal to sagittal by selecting the S-cube [B] and then 
press the right arrow button once.

14.	 Press Register.  The volumes should now register correctly (figure 3).  

15.	 To save the transformed match volume (Register_MRI_Match), choose File > Save 
Transformed; the transformed volume can be saved to disk or to the Analyze 
workspace.

16.	 To save the fused volume, choose File > Save Fused; the fused volume can be 
saved to disk or to the Analyze workspace.

17.	 Close the 3-D Voxel Registration module before proceeding to the next exercise.
Figure 3

Saving

Exercise 39 : Image Registration Mutual Information Registration
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Measurement
Analyze 10.0
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1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Line Profile module (Measure > Line Profile).

3.	 Open the Slice window (Generate > Slice) to move through the volume image.  Set 
the Slice to 97 and click Done. 

4.	 To calculate the intensity values along a straight line in this slice, select the Line tool 
in the main Line Profile window (figure 1). 

5.	 Position the cursor on the image and click to begin drawing.  The Sequence 
window (Generate > Sequence) provides X and Y coordinate slider bars for precise 
positioning of lines.  

6.	 The Profile window (figure 2) will automatically 
be returned when a line is drawn, displaying the 
intensity profile of the line.  The Profile window 
allows profiles, statistics, distances, and FWHM 
(full width half max) measurements to be logged.  

7.	 Click Log Profile in the Profile window. To save the Line Profile Log as a .stats 
file for use in another application (such as Microsoft Excel), select Save in the Log 
window.

8.	 Select the Trace tool in the main Line Profile window to draw a freehand trace. 

9.	 Select the Caliper tool (figure 3), an Angle Measure window will automatically be 
returned.  The Caliper tool provides a series of repositionable points and lines, 
enabling measurement of user-specified angles and distances on a selected slice.  
The Angle Measure window will automatically update with any repositions. 

10.	 Close the Line Profile module before proceeding to the Additional Task.

The Line Profile module enables calculation of image intensities along straight lines and freehand traces.  Coordinate points and angle 
measurements can also be made.  All measurements can be logged and saved to disk. 

note	 To log FWHM, open the 
Profile Options window 
(Generate > Profile) and set 
‘Full Width Half Max’ to ‘On’.

  tip	 If a structure of interest is in another orientation, choose Generate > Orientation to 
choose between transverse, coronal, and sagittal orientations, or define your own 
oblique orientation.

Figure 1

Figure 2

Figure 3

Exercise 40 : Line Profile Calculating Image Intensities Along a Straight Line
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1.	 The Radial Sequence tool in the Line Profile module enables users to 
sample a radial sequence of profiles.

2.	 Load the VH_Abdomen.avw data set from the $:\BIR\images\
TutorialData directory.

3.	 Open the Line Profile module (Measure > Line Profile).

4.	 Open the Profile Options window (Generate > Profile) and set Full 
Width Half Max to On.

5.	 Select the Line tool and then draw a line starting in the middle of the 
right femur, finishing outside (figure 3). 

6.	 Open the Radial Sequence tool (Generate > Radial Sequence).

7.	 Set the Angle Increment to 10 (figure 4).  When sampling a radial 
sequence the angle is incremented until a full 360 degrees from the 
starting position has been sampled.

8.	 Set Log Profile, Log Stats, and Log FWHM to On.

9.	 Click Sample Radial Sequence.

10.	 When the process has run, a Stats Log, Profile Log, and 
FWHM Log (figure 5) will be returned. To save any of the log 
files, right click and select Save Log.

11.	 Close the Line Profile module before proceeding to the next 
exercise.

Figure 3

Figure 4

Figure 5
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1. Line Profile Radial Sequence Tool

Exercise 40 : Line Profile - Calculating Image Intensities Along a Straight Line
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The Region of Interest module allows users to define and measure 3-D regions. This exercise will demonstrate how to use the tools in the module to 
define regions of interest within a volume image.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Region of Interest module (Measure > Region of Interest).  

3.	 When the module is opened, an object map is automatically created to store defined 
regions.  To define a new region, make sure that the Object to Define: is set to 
***New*** [A] at the bottom of the window (figure 1).

4.	 The buttons along the left side of the window control the definition of regions on the 
images [B].  The buttons below the image display allow you to modify the defined 
regions [C].

5.	 The first slice of the volume is automatically displayed when the ROI module is 
opened.  You can move to a different slice using the Show Next and Show Previous 
Slice PowerBar buttons or by using the Slice slider bar [D].  The currently displayed 
slice number and orientation can always be seen in the lower left corner of the image 
display [E]. 

6.	 Define a rectangular region on slice 1 using the Rectangle tool.  Position the cursor 
on the image display, then, click and drag the cursor out to size the rectangle, when 
you release the mouse button the new region ‘1.Object’ will be created and added to 
the object map (figure 2).  

7.	 Copy the region to the next slice (slice 2) by pressing the Copy Regions Forward 
PowerBar button once.  

8.	 Regions can be modified using the buttons found below the image display.  Select the 
Move button.  Position the cursor near the region you wish to modify, then click and 
drag the cursor; any movement of the cursor will move the region.  Also try using the 
Rotate and Scale buttons (found directly to the right of the Move button).  

tip	 The + and - keyboard keys 
can also be use to move 
through the data set.

tip	 Holding the <Ctrl> key while sizing will force a square.

Figure 1

Figure 2

Exercise 41 : Region of Interest Defining Regions

ROI Interface

Rectangle Tool
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9.	 Add a new region to slice 2 using the Oval tool (figure 3). 

10.	 Press Copy Regions Forward to copy the regions to slice 3.

11.	 Select the Move button again.  To move all regions on a slice simultaneously, hold the 
<Ctrl> key while moving the regions as described in step 7.  When you release the 
mouse button, a dialog box will be returned asking if you would like to ‘Move Regions 
in: This Slice Only, the Entire Object Map, or Cancel the move’, click This Slice Only.

12.	 Press the Show Next Slice PowerBar button to move to slice 4.  

13.	 Since the ‘Show Next Slice’ button was pressed, and not the ‘Copy Regions Forward’ 
button, there are currently no regions defined on slice 4.  Define a region on slice 4 
using the Polygon tool.  

14.	 To begin defining the polygonal region, position the cursor on the image display and 
click once to set a starting point.  Move the cursor outward to specify the length and 
direction of the first polygon side.  To set a vertex and begin drawing another side, 
click once.  Double-click to close the polygon (figure 5).  

15.	 If after defining the region it is unsatisfactory, click the Undo button.  

16.	 Press Show Next Slice to move to slice 5. 

17.	 Define a region on slice 5 using the Manual Trace tool.  Position your cursor 
on the image display, then click and hold the mouse button to begin drawing the 
trace, release the mouse button to end the trace.  The last point of the trace will be 
automatically connected to the first point of the trace.  

tip	 Holding the <Ctrl> key while 
sizing will force a circle. 

Figure 3

Figure 5

Oval Tool

Polygon Tool

Manual Trace Tool

Exercise 41 : Region of Interest Defining Regions
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18.	 If you make a mistake while tracing, continue holding the mouse button down, and 
press the <u> keyboard key.  The trace will slowly back up from the current position 
until the <u> key is released.  Try this by drawing a line on the image, and while 
continuing to hold the mouse button down, press the <u> key.  Once the trace 
has backed up half way, release the <u> key and continue your trace in a different 
direction.

19.	 To define a region without having to continuously hold down the mouse button, right-
click on the image display and choose the Button Passive option [F].  When ‘Button 
Passive’ is selected, simply click on the image display to begin the trace, and then 
click again when you are ready to end the trace and define the region.  The ‘Button 
Passive’ option is available for all region definition tools.

20.	 Right-click and deselect the Button Passive option.  Then, click Clear Regions [G] on 
the left side of the window to clear all regions defined on this slice.

21.	 With the Manual Trace tool still selected, check the Smart Edge option [H].  The 
‘Smart Edge’ option searches for edges (areas of high gradient) when drawing a trace 
with the Manual Trace or Spline tools.  Click once to begin a trace along an edge in 
the image display, letting ‘Smart Edge’ determine the path, click again to lock that 
portion of the trace.  When the region of interest has been defined, double-click to end 
the trace.  Uncheck the Smart Edge option.

22.	 Press Show Next Slice to move to slice 6.

23.	 Define a new region on slice 6 using the Spline tool.  The Spline tool enables the 
drawing of splines with moveable control points.  Position the cursor on the image 
display and click once to begin drawing a spline, click once again to set a control 
point.  When the region of interest has been defined, double-click to close the spline.  

24.	 To modify the region with the spline control points, select the Move button and then 
drag any control point to a new location.

Figure 6

Spline Tool

Exercise 41 : Region of Interest Defining Regions
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1.	 When objects overlap, the resulting regions may not appear as expected.  
Since the object map is a one-to-one mapping of the voxels to an object, a 
voxel cannot be part of more than one object.  The ‘Intersections become 
part of:’ option (in the lower left hand corner) allows you to control how 
intersecting regions are handled.

2.	 Press Show Next Slice to move to slice 7.  

3.	 Choose File > Reset Object Map to clear all regions from the volume.  In the 
dialog box returned, click Continue without Saving.

4.	 Ensure that Intersections become part of: is set to Defined (figure 7).  

5.	 Select the Rectangle tool and define a region. 

6.	 Now, select the Oval tool and define a region that overlaps the rectangle. 

7.	 The intersecting area becomes part of the region being defined, 2.Object 
(figure 7).

8.	 Click Undo button and then set Intersections become part of: to Existing. 

9.	 Select the Oval tool and again define a region that overlaps the rectangle.

10.	 The intersecting area now becomes part of the existing region, 1.Object 
(figure 8).

11.	 Click Undo and then set Intersections become part of: to New.

12.	 Select the Oval tool and again define a region that overlaps the rectangle.

13.	 The intersecting area now becomes a new region, 3.Object (figure 9).

14.	 Close the Region of Interest module before proceeding to the next exercise.

Figure 7

Figure 9Figure 8
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1. Intersecting Regions

Exercise 41 : Region of Interest Defining Regions
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This exercise will demonstrate how to use more advance region definition tools in the Region of Interest module to define objects of interest within a 
3-D volume image.  The exercise will also show you how to measure these objects.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.  
The data set may be available in the Analyze workspace if you have completed 
Exercise 41: ROI Defining Regions.  

2.	 Open the Region of Interest module (Measure > Region of 
Interest).  

3.	 Using the slice slider below the image display, move to Slice 
122.  

4.	 In the main ROI window, select the Auto Trace tool.  

5.	 Position the cursor near the center of the brain and click to set a seed point.  The ROI 
window will automatically update once a seed point is set to display a double-ended 
slider bar (to specify a threshold range) and other Auto Trace parameters (figure 1).

6.	 Use the double-ended slider bar to set the threshold minimum to 34 [A] and the 
threshold maximum to 129 [B].  Then, click Apply [C].  The double-ended slider bar 
will disappear and the new region will be named ‘1.Object’.

7.	 Press the Copy Regions Forward PowerBar button once.  The auto trace will be 
copied to the next slice.  Notice that the auto trace is recalculated for each slice based 
on the set threshold range.  

8.	 Press Copy Regions Forward until the auto trace has been applied to all the 
remaining slices containing brain matter, (until approximately slice 181).   

9.	 Once you have copied the region forward to the remaining slices, 
choose Tools > Show Rendering to open the Render Tool and 
view a 3-D rendering of the defined object (figure 2).  Click Done to 
dismiss the window.

10.	 Open the Objects window (View > Objects).  Select Object.1 from 
the Object drop-down menu and change Name of Object.1 to Brain.  
Click Done to dismiss the window. 

note	 You can change the 
image display size within 
the Size window (View > 
Size) or with the Magnifier 
PowerBar buttons.

tip	 If you placed your seed point towards the 
outside of the brain, it will eventually be 
copied forward to an area of a slice that 
does not contain the brain.  Select the 
‘Move’ button and move the seed point to 
the middle of the brain, then, continue to 
copy the region forward.  To learn more 
about editing regions see the Additional 
Task at the end of the exercise.

Figure 1

Figure 2

Exercise 42 : Region of Interest Defining Regions and Volume Measurements
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11.	 Open the Sample Options window (Generate > Sample Options).  

12.	 In the Sample Options window set the following (figure 3):
•	 Sample Type: Object(s), check the Brain object
•	 Summing: On
•	 Sample: All Slices
•	 Sequence Display: Off
•	 Log Stats: On

13.	 Click Configure Log Stats to open the ROI Stats window.  The ROI Stats window 
displays all statistics that can be returned for the ‘Stat Type’ selected in the Sample 
Options window (in this case the ‘Intensity’ Stat Type).  All statistics with a check mark 
in the ‘Log’ box to the left will be reported in the ROI Stat Log when the defined object 
is sampled.  

14.	 Click Sample Images.  The module will now sample the defined object (‘Brain’).  

15.	 The ROI Stat Log will automatically be returned, displaying the object statistics (figure 
4).  Click Done; in the dialog box returned click Discard, then Exit.

16.	 In the Sample Options window switch Summing to Off and Sequence 
Display to On.

17.	 Click Sample Images to sample the object again.  This time each slice 
will be displayed as it is sampled as ‘Sequence Display’ is now set to 
‘On’.  Notice the difference in time taken to sample the entire volume.  
The object statistics for each slice will be reported in the ROI Stat Log, 
as ‘Summary’ is set to ‘Off’.

18.	 In the Sample Options window, set Sample to Slices Specified in 
Slice Menu.  

19.	 Open the Slice window (Generate > Slice) and set Slice to 122 (the first slice with 
the object) and Number to 59 (the number of slices after 122 on which the object 
appears) (figure 5).

Figure 3

Figure 4

Measuring Regions

Exercise 42 : Region of Interest Defining Regions and Volume Measurements
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20.	 Click Sample Images.  Only the slices specified in the Slice window will be sampled. 

21.	 Experiment sampling the data with the different Stat Types available in the Sample 
Options window, for a full explanation of statistic types choose Help > User’s Guide 
in the main ROI window.  

22.	 To learn about editing regions complete the following Additional Task.  

Figure 5

Exercise 42 : Region of Interest Defining Regions and Volume Measurements
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1.	 Using the Show Next and Show Previous Slice PowerBar buttons, review 
the ‘Brain’ object (defined previously) slice-by-slice to determine if the auto 
trace leaked into other structures.

2.	 On slices where the auto trace leaked, select the Edit Region button and 
draw in the edge of the brain where the leak occurred. Areas beyond that 
edge will be removed from the object on that slice.

3.	 Next, use the slice slider below the image and move to slice 62.

4.	 Ensure that the Object to Define is set to Brain (at the bottom of the ROI 
window). Then, trace the brain on slices 62-121 using the Auto Trace or 
another region definition tool.

5.	 Once you have traced the ‘Brain’ object on slices 66-121, choose Tools > 
Show Rendering to open the Render Tool and view a 3-D rendering of the 
define object (figure 1). Click Done to dismiss the window.

6.	 Open the Sample Options window (Generate > Sample Options) and set 
Summing back to On and Sample to All Slices.

7.	 Click Sample Images in the main ROI window to sample the ‘Brain’ object as 
it is defined on slices 66-181.

8.	 Choose File > Save Object Map to save the object map with the ‘Brain’ 
object.

9.	 Close the Region of Interest module before proceeding to the next exercise.

Figure 1
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1. Editing Regions

Exercise 42 : Region of Interest Defining Regions and Volume Measurements
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As well as allowing users to define and measure objects defined in the module the Region of Interest module also allows users to load and measure 
object maps created in other modules.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.  
The data set may be available in the Analyze workspace if you have completed 
exercise 45 or 46.  

2.	 Open the Region of Interest module (Measure > Region of Interest).  

3.	 Choose File > Load Object Map and load the MRI_3D_Head.obj object map from the
$:\BIR\images\TutorialData directory.

4.	 Open the Objects window (View > Objects) and set Control to by Attribute.

5.	 Notice that this object map contains several objects.  With the Display attribute 
selected, switch the Lenticular and Caudate objects to On.

6.	 Open the Slice window (Generate > Slice) and navigate through the volume, the 
objects with the ‘Display’ attribute set to ‘On’ will be seen on the images (figure 1).  

7.	 Open the Sample Options window (Generate > Sample Options). 

8.	 In the Sample Options window set the following:
•	 Sample Type: Object(s), check Brain
•	 Summing: On
•	 Sample: All Slices
•	 Sequence Display: Off
•	 Log Stats: On

9.	 Click the Sample Images button to sample the ‘Brain’ object.  

10.	 The ROI Stat Log will automatically be returned, displaying the object statistics 	
(figure 2).  Note the volume given is only for the ‘Brain’ object, not the entire brain.  To 
find the total volume of the brain you need to obtain the volume of the objects that 
make up the brain – in this exercise this includes the ‘Brain’, ‘Ventricle’, ‘Lenticular’, 
and ‘Caudate’ objects.  

11.	 Click Done to close the ROI Stat Log; in the dialog box returned click Discard,
then Exit.

Figure 1

Figure 2

Exercise 43 : Region of Interest Measuring Objects in Object Maps



Analyze 10.0 Essential Training Guide 120

12.	 In the Sample Options window, check the Ventricle, Lenticular, and Caudate objects 
(the ‘Brain’ object should already be checked). 

13.	 Click Sample Images button.  The individual volumes for each object will be returned 
to the ROI Stat Log. The sum of these volumes is the total brain volume.

14.	 To have the volume of the objects added together automatically for the total volume, 
set Combine Objects to Yes under the selection area (figure 3).

15.	 Click Sample Images. The total brain volume will now be returned to the ROI Stat 
Log (figure 4)

Figure 3

Figure 4

Exercise 43 : Region of Interest Measuring Objects in Object Maps
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1.	 Select File > Load Object Map and load the object map created 
in Exercise 33: Object Extractor - Automated Segmentation.

2.	 Follow steps 7-9 in the above exercise to calculate the volume 
of the ‘Extracted’ Brain object.

3.	 Compare the volume returned in the ROI Stat Log (figure 5) to 
that of the brain volume obtained in step 15.

4.	 Close the Region of Interest module before proceeding to the 
next exercise.

Figure 5
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This exercise will provide instructions on how to generate a histogram for an individual slice within a volume, an entire volume, and for a defined 
object.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory. 

2.	 Open the Region of Interest module from the Measure menu (Measure > Region of 
Interest). 

3.	 Use the slice slider directly below the image, and move to slice 97.

4.	 Open the Histograms window (Generate > Histograms).

5.	 In the Histograms window, set Histogram Display to On and set Log Histogram to On.

6.	 In the main ROI window click on the image. The module will sample voxel intensity vs. 
occurrences. The results will be displayed as a histogram and saved to a Histogram Log 
file. The Histogram Log file can be saved by right-clicking in it and selecting Save Log.

7.	 Close all windows associated with the ROI module.

Figure 1

Figure 2 Figure 3

Sampling a Single Slice

Exercise 44 : Region of Interest Histogram Analysis
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1.	 Select the MRI_3D_Head.avw data set and open the Region of Interest module.

2.	 In the Histograms window, set Histogram Display to On and set Log 
Histogram to On.

3.	 Next open the Sample Options window (Generate > Sample 
Options).

4.	 In the Sample Options window, set Summing to On and set Sample 
to All Slices (figure 4).

5.	 In the main ROI window click on the image display to start the 
sampling process.  The module will sample voxel intensity vs. 
occurrences for the entire volume.  The results will be displayed 
as a histogram and saved to a Histogram Log file (figure 5).  The 
Histogram Log file can be saved out of Analyze by right-clicking in it 
and selecting Save Log.

6.	 Close all windows associated with the ROI module.

1.	 Select MRI_3D_Head.avw and open the Region of Interest module.

2.	 Select File > Load Object Map and load MRI_3D_Head.obj from the $:\BIR\images\
TutorialData directory.

3.	 Open the Histogram window (Generate > Histogram).

note	 If you want to sample all slices at the same time, but do not want 
to ‘sum’ the information, simply set Summing to Off, intensity vs. 
occurrence will be reported for each individual slice in the volume. 
For a quicker sampling time, set Sequence Display to Off.

Figure 4

Figure 5

Sampling a Volume

Sampling an Object

Exercise 44 : Region of Interest - Histogram Analysis
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4.	 In the Histograms window set Histogram Display to On and set Log Histogram to 
On.

5.	 Next open the Sample Options window (Generate > Sample Options), and set the 
following parameters:

•	 Sample Type to Object(s)
•	 Uncheck all objects except the Brain
•	 Summing to On
•	 Sample to All Slices

6.	 Click on the Sample Images button to start the sampling process. The module 
will sample voxel intensity vs. occurrences for the brain object. The results will be 
displayed as a histogram, and also saved to a Histogram Log file (figure 7). The 
Histogram Log file can be saved out of Analyze by right-clicking in it and selecting 
Save Log.

7.	 Close all windows associated with the ROI module before proceeding to the next 
exercise. 

Figure 6

Figure 7

Exercise 44 : Region of Interest - Histogram Analysis
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ROI Stat Log files (.stats) and Histogram Log files (.hst) can be saved out of Analyze as text files.  These text files can be imported into third party 
statistical applications such as Excel, for further statistical analysis. This exercise will demonstrate how to load a .stats file into Excel.  Note that the 
process for loading a .hst file is identical. 

1.	 Open Excel, then select File > Open.

2.	 In the Open window, select All Files (*.*) from the File Type drop menu.

3.	 Navigate to and open the .stats file.

4.	 The Text Import Wizard will appear. 

5.	 In Step 1 of 3 Under Original Data Type select Delimited and click Next 
at the bottom of the screen.

6.	 In Step 2 of 3 of the Text Import Wizard, under the Delimiters select 
Space, and deselect any other options. Then click Next.

7.	 Step 3 of 3, in the Data Preview section, simply click Finish at the 
bottom of the screen. Your stats file will now appear in an excel 
worksheet.

Exercise 45 :  Importing .Stat Files to Excel
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The Stereology module estimates volume and surface area using the stereological method of point counting.  The point counting method consists 
of overlaying the images entirely with a randomly positioned and oriented systematic array of test points and counting the number of occasions on 
which a point lies within the feature of interest.

1.	 Load the Canine_Chest_CT.avw data set from the $:\BIR\images\TutorialData 
directory.

2.	 Open the Stereology module (Measure > Stereology).

3.	 The intensity scaling of the images must be changed so that they are viewable.  Open 
the Intensities window (View > Intensities) and change the Maximum to 145.  Click 
Done to dismiss the window.

4.	 Open the Grid Parameters window (Generate > Grid) to set up a sampling grid that 
encompasses the heart (figure 1).

5.	 The heart first appears around slice 42 and remains visible until slice 94.  Set the 
Starting Grid Slice to 42.  Using Stereology, it is not necessary to sample every slice, 
set the Grid Slide Increment to 3 and Number of Grid Slices to 17.  

6.	 Click Generate Grid.  Then, click Done to dismiss the Grid Parameters window.

7.	 In the main Stereology window, click in the image display and drag your cursor 
over all grid points that lie on the heart (figure 2).  If points that are not on the 
heart are mistakenly selected, hold <Shift>, click and drag the cursor over to 
deselect them.  

8.	 When you are finished selecting points on the current slice, press the Next Slice 
PowerBar button to move to the next grid slice (specified earlier in the ‘Grid Slice 
Increment’ field) and select the appropriate points.  Continue in this manner until 
all grid slices have been examined. 

9.	 Open the Statistics window (Generate > Statistics) to view the estimated 
volume of the heart.  

10.	 Close the Stereology module before proceeding to the next exercise.

tip	 Open the Size 
window (View > 
Size) to increase 
the size of the 
image display.

tip	 The Orthogonal tool (Tools > Orthogonal) shows the grid point location 
in the three orthogonal orientations and is helpful on points that are on 
or near the edge of the heart.

Figure 1

Figure 2

Exercise 46 : Stereology Estimating Volume
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The Object Counter module allows a user to count the number of objects that occur on each slice of a loaded data set. The goal of this exercise is to 
count and measure cells from light microscopy data.

1.	 Load the FatCells.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Object Counter module (Measure > Object Counter).

3.	 Select the PreProcess tab.  This tab allows for correction of intensity fall off near the 
edges of the image data by applying an Inhomogeneity Correction filter.  Using the 
default settings, click Apply.

4.	 Select the Connect tab.  This tab (figure 1) allows for the specification of region 
growing parameters used to segment objects, including whether the objects should be 
segmented in 2D or 3D (for this exercise, we will use 2D).  

5.	 With 2D selected, set the following ‘Connect’ tab parameters:
•	 Max. Size: 3217
•	 Min. Size: 50
•	 Threshold Minimum: 106 (this will allow the cells to be separated from the 

background) 

6.	 Click Apply.  All of the objects satisfying the size and threshold criteria will be 
identified and outlined in red on each slice of the volume.  

7.	 Use the Slice slider bar to move through the slices in the data set.  Return to slice 1 
before proceeding to the next step. 

8.	 Select the Limits tab.  This tab allows interactive screening of segmented objects 
based on position and shape characteristics. 

9.	 With the Position button selected, increase the Y Min to 11 using the arrow key 
found to the right.  This will cause any objects with a Y coordinate less than 11 to be 
removed (objects along the bottom of the image display in the transverse orientation).

tip	 The ‘Max’ and ‘Min Size’ parameters can be set by selecting the Interactive Size 
buttons next their respective text entry fields.  Specify each by selecting either 
button and then drawing an ellipse around the largest/smallest object to be counted.  
Holding the <Ctrl> key while tracing forces the ellipse to be a circle.

tip	 The ‘Calibrate’ tab provides the ability to 
determine the dimensions of pixels in an 
image.  By drawing a line over a known 
distance in the image, such as on a ruler 
or structure of known size, the correct 
pixel dimensions can be established and 
the image can be calibrated for real-
world measurements. Slice thickness 
can also be entered for 3D data.

Figure 1

Exercise 47 : Object Counter Counting Cells
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10.	 Reduce the X Max to 470 using the arrow key and observe the effect (seen along the 
right side of the image display).

11.	 By default, no shape screening is performed on the objects.  Select the Circularity 
button, and check the Restrict Circularity option.  Using the slider bar set the 
Circularity Maximum to 1.8.

12.	 Experiment with the effects of restricting Intensity, Diameter, Area, Perimeter, and 
Rectangularity.

13.	 Select the Edit tab.  This tab allows objects to be added, deleted, and modified 
manually. 

14.	 Select the Measure tab.  This tab allows specification of the measurement statistics to 
be returned in the Object Counter Stats window.  

15.	 To obtain a cell count on each slice click Log Measurements (without checking any 
of the options).  The Object Counter Stats window will be returned, displaying a cell 
count for each slice (figure 2).  Click Done to dismiss the window. 

16.	 In the main Object Counter window select the Measure tab again.  Check Area and 
then click Log Measurements.  The Object Counter Stats window will be returned, 
displaying an object count for each slice and the average area of the objects on each 
slice.  

17.	 To view the area for each individual object, select the Detailed option at the bottom of 
the Object Counter Stats window.  When the ‘Detailed’ option is selected, click on any 
object in the Object Counter Stats window to highlight the object in the image display 
or vice versa (figure 3).

18.	 Experiment with other measurements available in the Measure tab.  

19.	 Close the Object Counter module before proceeding to the next exercise.

tip	 To save the Object Counter Stats as a .stats file for use in another application 
(such as Microsoft Excel), right-click in the window and select Save Log.

Figure 2

Figure 3

Exercise 47 : Object Counter - Counting Cells
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The Tree Analysis module allows users to take an in-depth look at tree-like structures in medical images, such as coronary arteries. Branching 
angles, segment lengths, and cross sectional areas can all be measured with the module. This exercise will demonstrate how to use Tree Analysis to 
create, review, and sample a coronary tree.

1.	 Load the Coronary_CT.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the Tree Analysis module (Measure > Tree Analysis).

3.	 Open the Slice window (Generate > Slice) and set Slice to 64.

4.	 Open the Generate Tree window (Generate > Generate Tree).

5.	 Set the Threshold Minimum to 130 and Maximum to 255.

6.	 Since the thinning algorithm used in the tree generation process is sensitive to holes 
within structures it is advised that the Fill Holes option always be left checked.

7.	 Leave the Shortest Skeleton Branch and the Maximum/Minimum Tree Length 
fields as their defaults. 

8.	 Set the Approximate Root Location values to X: 56, Y: 69, Z: 125. Note that you 
can also set the Approximate Root Location by clicking in the main module window.

9.	 Click Generate Tree. The Tree Plot window will automatically be returned when the 
extraction is complete. The Tree Plot window can be used to view the trees generated 
and provides a number of tools for in-depth analysis of the structures.

10.	 To view the trees generated in the extraction process, use the Tree drop-down menu 
[A] in the Tree Plot window. Select Tree 2.

11.	 Select all four of the Views buttons [B] to display the left, top, right and bottom views 
of the tree. 

12.	 Check Render [C] from the Display options at the bottom of each window. A MIP 
rendering will be displayed behind each view of the trees. Experiment with the 
different Label and Display options.

Figure 1

Figure 2

Tree Generation

Tree Display Options

Exercise 48 : Tree Analysis In Depth Examination of Coronary Arteries
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13.	 Several of the Action options can also be used to manipulate the tree display. With Action 
set to Zoom, click the + and - buttons to increase or decrease the tree display size. To 
magnify a specific area in a tree, click and drag a rectangle over the area in any of the 
displayed views.

14.	 Now, set Action to Rotate. Click in any of the views and drag the tree to a new rotation 
angle.

15.	 To return all views to their default display, right-click on any of the views and select Reset.

16.	 A new tree can be added by clicking the New Tree button. With Action set to Add Point, 
construct the new tree by drawing branches over the rendering in any of the views. The 
Add Point action can also be used to add branches to an existing tree. 

17.	 An entire tree can also be deleted by selecting the Delete Tree button. Click Undo to 
recover deleted trees.

18.	 To only delete branches from a tree, set Action to Delete Branch. Click on a branch 
in any one of the views to delete it, all branches below it will also be removed from the 
tree.

19.	 Set Action to Distance to Root and check the Log option. Click on a point in the tree; 
the distance to the tree root from that point will be returned to a Tree Distance Log 
(figure 3).

20.	 Select Stats at the bottom of the Tree Plot window.

21.	 The Stats Option window returned allows specification of parameters used to calculate 
the various tree statistics (figure 4). The location where the resulting stats files are 
saved can also be set in this window. To calculate stats, press the Calculate Stats 
button.

22.	 The Tree Stats window (figure 5) displays the ‘Summary’ statistics for each branch of the 
tree. Select the ‘Detailed’ option from the bottom of the window to view statistics on each 
of the points in the branches.

Exercise 48 : Tree Analysis in Depth Examination of Coronary Arteries

tip	 When a point is selected in the ‘Detailed’ view, a 
BAP Plot will be returned and the point’s branch 
will be highlighted in the Tree Plot window.

Figure 3

Figure 4

Figure 5

Tree Manipulation
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1.	 Check Internal from the Display options in the Tree Plot window (figure 1).

2.	 Set Action to Select and click on the point in the tree from which you wish to 
begin your fly-through movie. The Renderings window will be returned.

3.	 By default, the Renderings window will display both fly-through sequence 
views: Away from Root on the left and Toward Root on the right (figure 2). 
Preview the sequence using the slider bar.

4.	 To generate the fly-through movie, right-click in the Renderings window and 
from the Sequence sub-menu, specify the direction of movement and the 
viewpoint for the movie. The movie will then automatically be saved to the 
main Analyze workspace and can be viewed with the Movie module (Display 
> Movie) (figure 3).

5.	 Close the Tree Analysis and Movie modules before proceeding to the next 
exercise.
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1. Generating a Fly-Through Movie

Exercise 48 : Tree Analysis in Depth Examination of Coronary Arteries

Figure 1

Figure 3

Figure 2
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Epilepsy Seizure Focus Localization with SISCOM (Subtraction Ictal SPECT CO-registered to MRI) automates the technique for advanced imaging 
of epilepsy patients that was developed with Analyze at the Mayo Foundation. This method uses a combination of SPECT and MRI imaging for 
improved diagnosis of areas of regional activation in the brain during a seizure. The SISCOM technique requires acquisition of ictal (during the 
seizure) and interictal (resting, or between seizures) SPECT images and an MRI volume spanning the entire brain. This exercise will demonstrate 
how to use the SISCOM module within Analyze.

1.	 Load the data sets SISCOM_Ictal_SPECT.avw, SISCOM_Interictal_SPECT.avw, 
and SISCOM_MRI.avw from the $:\BIR\images\TutorialData directory.

2.	 Select the data sets in the following order (hold down the <CTRL> key to select 
multiple data sets, or click using the middle mouse button):
•	 SISCOM_Ictal_SPECT.avw
•	 SISCOM_Interictal_SPECT.avw
•	 SISCOM_MRI.avw
Note the selection order: Ictal, Interictal, MRI. If the data is not loaded in this order the 
SISCOM procedure will fail to run correctly.

3.	 Open the SISCOM module (Apps > SISCOM).

4.	 Open the Register SPECT option (Process > Register SPECT) to compute an 
activation map.

i.	 Set the Interictal SPECT minimum Cerebral Activity Threshold level to 75 [A]. 
Note the change in the binary image.

ii.	 Ensure that the Interictal Transformation Type is set to Linear [B].

iii.	 Use the Activation Level slider bar to set the standard deviation to 2.0 [C].

iv.	 Next, select the Register and Map button. The Register SPECT tool will  
automatically register, normalize, subtract, select the statistically significant 
voxels of activation, and output the activation map based on the parameters 
specified above. Note that the tool will update, displaying the Activation Map [D].

5.	 Select Next to continue onto the next step of the SISCOM procedure, MRI brain extraction.

Figure 1

Exercise 49 : SISCOM
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6.	 The Extract MRI Brain tool allows for segmentation of the brain 
for SPECT-MRI registration.

7.	 Right-click in the MRI data display window and select the 
Intensities option. In the Intensity (MRI) window returned, 
change the Maximum to 101 then click Done to close the 
Intensity Tool.

8.	 Use the slider bar to adjust the minimum and maximum 
threshold values to obtain the best definition of the cortical 
boundary as possible. In this case, the threshold values do not 
need to be adjusted.

9.	 Select Extract Brain to segment the brain. After segmentation 
is complete, the extracted brain is automatically displayed in 
the Extract MRI Brain tool. The segmentation can be reviewed 
using the Slice slider bar (figure 2).

10.	 Select Next to continue to the next step, registration of the 
SPECT data sets to the MRI data sets. 

11.	 The Fuse SPECT & MRI tool will automatically open and immediately run the Match 
Surfaces process, registering the SPECT data sets to the MRI data set and displaying 
the Activation Map overlaid on the MRI data set. The activation map and MRI can be 
reviewed using the orthogonal orientation buttons and the slice slider bar (figure 3).

12.	 Select Fuse Volumes. The activation map and MRI will be fused and automatically be 
saved to the Analyze workspace. Select Done to close the Fuse SPECT & MRI tool. 
Also close the Extract MRI Brain and Register SPECT tools.

Figure 2

Figure 3

Exercise 49 : SISCOM
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13.	 Select the Compare Tool option (Process > Compare Tool). The Compare Tool 
provides an interface for users to display and visually inspect the accuracy of the 
registration and fusion of the volumes created in the SISCOM process. Use the drop 
down menu options under each image [A] to select the volumes to compare (figure 4). 
Select Done when review is complete.

14.	 Select the Create Object Map option from the File menu to generate an object map 
based on the areas of activation.

15.	 Select Output Object Map. The object map will be automatically saved to the location 
specified using the File option. The Render tool (figure 5) will automatically open, 
allowing for interactive review of the object map.

16.	 Close all windows related to the SISCOM module before proceeding to the next 
exercise.

Figure 4

Figure 5

Exercise 49 : SISCOM
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The Analyze Mayo 3D Brain Atlas add-on provides a unique 3D implementation of the Talairach anatomical atlas of the human brain.  The Mayo 3D 
Brain Atlas add-on allows for 3D navigation of the atlas and interactive query and reporting of atlas-based coordinates in many common volumetric 
and neuroanatomical and neurofunctional frames of reference, including TT, MNI, SPM, FSL and ICBM coordinates.  In addition, atlas-derived 
neuroanatomical regions can be output from the module and then utilized directly in many other Analyze modules. This exercise will demonstrate 
how to use the Mayo 3D Brain Atlas add-on.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Select the MRI_3D_Head.avw data set then open the Mayo 3-D Brain Atlas module 
(Apps > Mayo 3D Brain Atlas).

3.	 The PowerBar buttons in the main Mayo 3D Brain Atlas window are set up in 
the sequence of operations performed. The first step to using the atlas is AC-PC 
based alignment of the loaded image data to the Talairach-Tournoux coordinate and 
proportional grid system.

4.	 Open the Align AC-PC window (Tools > Align AC-PC).

5.	 Use your cursor to move the AC and PC points to the appropriate location on the 
sagittal image. Enlarging the image may help to identify the AC and PC; right-click on 
the display and select Size > Double. Note that the left and right arrows and rotation 
buttons can be used to adjust the data set to correct for symmetry.

6.	 Select the AC point and move it to the appropriate location. The magnify window will 
automatically display helping you to determine the precise location of the AC (figure 1). 

7.	 Select the PC point and move it to the appropriate location.

8.	 Select Align AC-PC. The image volume will realign to the AC-PC. 

9.	 Select Next to open the Extract Brain Tool. A seed point and threshold range are 
automatically set by the Extract Brain Tool. These can be adjusted if necessary. 

10.	 Check the Fill Holes after Extraction option and then select Extract Brain.

11.	 The extracted brain can be reviewed using the Slice slider bar (figure 2). 

Figure 2

Figure 1

Exercise 50 : Mayo 3D Brain Atlas
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12.	 Select Next to open the Adjust Registration tool (figure 3). If needed the atlas can 
be adjusted. Right-click in any of the orthogonal display panes and select Restrict 
> None. Note the right-click menu also provides options to display the loaded or 
extracted volume and increase the display size. 

13.	 The grid can now be manipulated.  Move the grid lines in any of the orthogonal 
displays to adjust the atlas.  When you are finished making adjustments, right-click in 
any of the orthogonal displays and set Restrict back to “All.”

14.	 Move the yellow square marker in any of the orthogonal displays to move through the 
loaded volume. Note that when the marker is moved the name of the atlas region and 
the coordinates of the current marker point will appear in the lower left-hand corner of 
the window. 

15.	 To query specific structures by coordinates, navigate back to the main module window 
and select the Query Atlas button from the PowerBar.  

16.	 The Adjust Registration window and the Query Atlas window work together. The 
Query Atlas window will return the atlas structure and coordinates for the current 
location set in the Adjust Registration window. 

17.	 In the Adjust Registration window, move the Yellow marker to a location you wish to 
query. 

18.	 In the Query Atlas window click the Query button, the structure and location of the 
Yellow marker will be returned.  

19.	 Check the Query Range option and set the Range to 5.  Click the Query button again.  
All structures with in a 5 voxel range will be reported in the query window (figure 4).  
Please note: The information returned can be saved as a text file by right-clicking in 
the Query window and selecting the Save As option.  

20.	 Close the Query Atlas and Adjust Registration windows.

21.	 To save the atlas as an object map open the Generate Output window by clicking on 
the Output button in the PowerBar. 

Figure 3

Figure 4

Exercise 50 : Mayo 3D Brain Atlas
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22.	 In the Generate Output window returned (figure 5), make sure the following options 
are set:

	 i. Set Output What to Specified Atlas
	 ii. Set Space to Original Volume
	 iii. Set Which Atlas to Transverse
	 iv. Set Output As to Object Map

23.	 Next change Object(s) to Specified and then click on the List button. The Object List 
window returned allows you to select only the objects you wish to output to the object 
map, click Done to close the window and then set Object(s) back to All. 

24.	 Select Generate Output. The object map will be saved as ‘AtlasOutput_MRI_3D_
Head.obj’ in the specified directory. 

25.	 Select Done in the Generate Output window and close the Mayo 3D Brain Atlas.

26.	 To review the Atlas object map created, select the MRI_3D_Head data set from the 
Analyze workplace and then open the Multiplanar sections module.  Select File > 
Load Object Map and load the object map saved in step 23. Select the Traffic Signal 
icon to begin the sequence display of the data.

27.	 Close all windows before proceeding to the next exercise.

Figure 5

Exercise 50 : Mayo 3D Brain Atlas
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The MRI T2 Optimization Add-On provides the ability to enhance the relative contrast between different tissue types in T2 weighted MR images post-
acquistion. The add-on uses a piecewise non-linear intensity transformation based on priori knowledge. The prior knowledge is derived from training 
multiple post-processed data sets acquired at different relaxation (TR) and echo (TE) times. The transformation does not make any assumption on 
the pulse sequence parameters associated with the image to be projected. This exercise will demonstrate how to use the add-on to enhance a T2 
MRI data set.

1.	 Load the MRI_T2.avw data set from the $:\BIR\images\TutorialData directory. 

2.	 Open the T2 Projection add-on (Apps > T2 Projection)

3.	 The input, or pre-enhanced, T2 data is displayed on the left side of the window, the 
post enhanced data is displayed on the right side

4.	 Click Show Forward, until Slice 15 is displayed.

5.	 The Relaxation Time (TR) can be adjusted by selecting a value from the TR (msec) 
drop-down menu. Select 1800. Note that the post-enhanced display updates when a 
new value is selected.

6.	 Similarly, the Echo Time (TE) can be adjusted by selecting a value from the TE 
(msec) drop-down menu. Select 110.

7.	 To save post-enhanced T2 select the Create Projection button. The projection will be 
saved to the Analyze workspace. Note the enhanced images are named according to 
the TR and TE values used. For example MRI_T2_1800-110.

8.	 Close all windows associated with the T2 Projection module before proceeding to the 
next exercise.

Figure 1

Exercise 51 : T2 Projection



Analyze 10.0 Essential Training Guide 140

The Volume Metrics Add-On provides tools to assess the quality of multiple associated volumes, allowing the creation of a set of statistics based 
on the type of metric chosen. The add-on can be used to assess the similarity of two co-registered three dimensional volumes using 15 parametric 
or 12 non-parametric similarity indices. The add-on can also be used to assess the concordance of different segmentation results with ground truth 
data using 47 popular binary similarity metrics. This exercise will demonstrate how to compute similarity metric values for two related data sets.

1.	 Load the MRI_3D_Head.avw and the MRI_3D_Brain.avw data sets from the 
$:\BIR\images\TutorialData directory.

2.	 With both volumes selected, open the Volume Metrics module (Apps > Volume 
Metrics).

3.	 To calculate all of the statistics for a specific metric option, select the Metric Type [A], 
then click the Calculate Metrics button [B]. The metrics are calculated and displayed 
next to each Similarity Value [C].

4.	 To log the metrics in a log file, click on the Log Metrics button.

5.	 The Volume Metrics Log (figure 2) contains all of the metrics that are checked in 
the main window. To save the metrics log file to disk, right click in the log window and 
select Save Log.

6.	 Click Done to close the log screen. 

7.	 Close all of the windows associated with 
Volume Metrics before proceeding to the 
next exercise.

note	 Volume 1 is the input volume, while
	 Volume 2 is the comparison volume.

Figure 1Figure 2

Calculating and Logging Metrics

Exercise 52 : Volume Metrics
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The ITK Filters module enables the application of ITK smoothing, edge-detection, and feature-extraction filters to image data.  This exercise will 
demonstrate how to apply a filter in the ITK Filters module to your data.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the ITK Filters module (ITK > Filter).

3.	 Open the Preview Options window (Generate > Preview Options).

4.	 Select the Loaded and Preview Volumes option.  This will preview the original data 
set and a copy of the data set with any filter applied, side-by-side.

5.	 Open the Filters window (Generate > Filters). 

6.	 In the Filters window, select the Bilateral filter (figure 1).

7.	 Use the Slice slider bar to determine which slice you would like to preview the filter 
on; set to Slice 128.

8.	 Now, click Preview. The main module window will display the filtered slice on the left 
and original slice on the right (figure 2)

9.	 Preview several other filters, noting the effect of each.

10.	 To apply a filter to the data set, simply click Filter in the Filters window.  A dialog box 
will be returned stating that the action modifies the loaded volume, click Change a 
Copy of the Loaded Volume.

11.	 A filtered copy of your volume will be saved to the Analyze workspace.

12.	 Close the ITK Filters module before proceeding to the next exercise.

Figure 1

Figure 2

Exercise 53 : ITK Filters
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The ITK Segment 2-D module provides an interactive framework for applying sequential processing steps using ITK functions for segmentation of 
sets of 2-D slices based on region growing and level set methods.  This exercise will demonstrate how to use the ITK Segment 2-D module.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the ITK Segment 2-D module (ITK > Segment 2-D).

3.	 Use the Slice slider bar to move to slice 133, make sure that the image is displayed in 
the transverse orientation (select the T cube).

4.	 The SubRegion tab allows the user to limit segmentation to a specific region, helping 
decrease processing time.  Check the Use SubRegion option and set the following 
values (figure 1): 
•	 X: 63 and 120
•	 Y: 78 and 152
•	 Z: 1 and 187

5.	 Select the Smooth tab.  This tab provides several different methods for reducing 
noise on images.  Select the Gradient Anisotropic Diffusion type and click the 
Default button. 

6.	 Select the Edge tab.  This tab provides methods for generating gradient images 
required for some seed- and mask-based segmentation algorithms.  Select the 
Gradient Magnitude edge type. 

7.	 Select the Seed Based tab.  This tab provides different methods for performing seed-
based segmentation on the current volume.  Select the Fast Marching type. 

8.	 Click once inside of the left ventricle to set a seed point.  The right side will no longer 
be selected, set a second seed point by clicking once inside of the right ventricle 	
(figure 2).  Seed points can be reset by right clicking on the image display and 
selecting Reset Seed(s).

9.	 Select the Mask Based tab.  This tab provides options to enhance features found in 
the ‘Seed Based’ tab.  Select the Shape Detection type and set the 
Alpha value to -2.1.

Figure 1

Figure 2

Exercise 54 : ITK Segment 2-D
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10.	 At this point, we have exhausted our enhanced ITK functionality, but there are still 
some built in post-processing steps that can be performed.

11.	 Select the Morph tab.  This tab allows a number of post-processing steps, for 
example filling of small holes that still appear in the segmentation.  Select the 
4-connected Fill Holes option. 

12.	 Select the Output tab.  This tab provides a number of output parameters.  Change 
the output type to Binary.  If you wish to save this slice, click Save Slice (figure 3).  
The ‘Process Volume’ button does apply all steps to the entire volume, but a more 
successful 3-D segmentation can be performed in the ITK Segment 3-D module 
(exercise 41).

13.	 Close the ITK Segment 2-D module before proceeding to the next exercise.

Figure 3

Exercise 54 : ITK Segment 2-D
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The ITK Segment 3-D module provides a framework for 3-D segmentation using ITK algorithms.  This exercise will demonstrate how to use the ITK 
Segment 3-D module.

1.	 Load the MRI_3D_Head.avw data set from the $:\BIR\images\TutorialData directory.

2.	 Open the ITK Segment 3-D module (ITK > Segment 3-D).

3.	 Select the SubRegion tab (figure 1).  Check the Use SubRegion option and set the 
following values: 
•	 X: 51 and 127
•	 Y: 36 and 162
•	 Z: 86 and 144

4.	 The subregion can also be specified interactively in the image display with the mouse 
when the Adjust Subregion button (found directly below the image display) is 
selected.  Click Extract SubRegion.  

5.	 Select the Smooth tab.  Select the Gradient Anisotropic Diffusion type, and 
change the Time Step value to 0.0625.  Click Smooth Volume. 

6.	 Select the Edge tab.  Select the Gradient Magnitude edge type and then click 
Detect Edge.

7.	 Select the Seed Based tab and select the Fast Marching algorithm type.  

8.	 Select the New Seed button (directly below the image display), and click to set a seed 
point in each ventricle.

9.	 Click Seed Segment to apply the seed-based segmentation.

tip	 The module displays the data set in all three orthogonal orientations.  To update 
the display click on one of the display panes and move the cursor—the other two 
orientations will interactively update.

Figure 1

Exercise 55 : ITK Segment 3-D
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10.	 You can review the results of the segmentation with the Render Tool (Tools > 
Render).  Click and drag the rendering to rotate it, or click the direction buttons to 
quickly change views (figure 2).  You can leave this tool open, it will update as we 
modify our segmentation.  

11.	 Select the Mask Based tab.  Select the Shape Detection type and set the following 
and then click Mask Segment.

12.	 Select the Morph tab and choose the Dilate option and the 3-pass 2D Fill Holes 
option.  

13.	 Click Apply Morphology. 

14.	 Select the Output tab for options to output the segmentation results.

15.	 Choose the Binary option and click Output Volume to create a binary mask of our 
segmented volume in the Analyze workspace (figure 3).  

16.	 Also try selecting the Masked Grayscale option, and use the Output Volume button 
to output the resulting volume in the Analyze workspace.

17.	 Close the ITK Segment 3-D module before proceeding to the next exercise.

Figure 2

Figure 3

Exercise 55 : ITK Segment 3-D
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The ITK Registration module functions the same as the Analyze 3-D Registration modules with the exception of ITK function specific parameters.  
The exercise will provide an overview of the module.   

1.	 Load the Register_MRI_Base.avw data set from the $:\BIR\images\
TutorialData directory.

2.	 Next open the Load As module (File > Load As). Navigate to and select the 
Register_MRI_Match.avw data set from the $:\BIR\images\TutorialData 
directory. Select the Resize tab and check the Force Cubic option. Click Load.

3.	 Select the Register_MRI_Base.avw data set. Then, while holding down the 
<Ctrl> key, select the Register_MRI_Match.avw data set (resulting in both being 
selected).

4.	 Open the ITK Registration module (ITK > Registration).

5.	 Open the Blend window (Generate > Blend) and set the Blend Option to 
Red-Green (figure 1).

6.	 Press the Register PowerBar button or choose Generate > Register.

7.	 After registration is complete, evaluate the registration by moving the crosshair in 
any of the panes to navigate through the image data.

8.	 If you are satisfied with the registration, save a copy of the transformed match 
volume (Register_MRI_Match), choose File > Save Transformed. The 
transformed volume can be saved to disk or to the Analyze workspace.

9.	 If you are unsatisfied with the registration, reset by selecting the Reset Matrix button 
in the Manual Registration tool (Tools > Manual Registration). Adjusting the Match 
position manually and the ITK Registration Parameters (Generate > Parameters) 
(figure 2). For more information about the ITK Registration Parameters, please refer to 
the ITK Users Guide (www.itk.org/ItkSoftwareGuide.pdf).

10.	 Close the ITK Registration module.

Figure 1

Figure 2

Exercise 56 : ITK Registration
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